Oracle FAQ Your Portal to the Oracle Knowledge Grid
HOME | ASK QUESTION | ADD INFO | SEARCH | E-MAIL US
 

Home -> Community -> Usenet -> comp.databases.oracle -> Re: Oracle 7.0.9.3, XA, and Encina

Re: Oracle 7.0.9.3, XA, and Encina

From: Kees Verruyt <kverruyt_at_nl.oracle.com>
Date: 5 Nov 92 08:14:22 GMT
Message-ID: <3190@nlsun1.oracle.nl>

Alan Beal writes:
> Has anyone been successful using Oracle 7.0.9.3 with Transarc Encina
> 1.0.1a using the XA interface? Using embedded SQL, we get data
> retrieved on the first Encina transaction and then get invalid
> cursor after that (sqlcode = 1001). Oracle Support will not help
> because it is not a production product. Any ideas?
>
> Alan Beal alanb_at_owgvm0.vnet.ibm.com
 

Alan,

I struggled with this myself -- just compile your Pro*C program with

EXEC ORACLE OPTION (RELEASE_CURSOR=YES); Otherwise the Pro*C cursor cache gets in the way: Even if you CLOSE a cursor, Pro*C tries to keep it open.

It should work fine after that.

Note: Since this is ORACLE7, closing a cursor in the front-end isn't so bad since

      the parsed SQL is kept around in the ORACLE7 server SGA.

-- 
/*
EXEC SQL INCLUDE ORA_DISCLAIMER;
*/
-- This posting reflects the views of myself, not Oracle Corporation.
------------------------------------------------------------------------
Kees Verruijt                           Rijnzathe 6
Software Engineer Gateway development   3454 PV  DE MEERN
Oracle Europe                           The Netherlands
Email: kverruyt_at_nl.oracle.com           Tel: +31 3406 94886
   or: kverruyt_at_oracle.nl               Fax: +31 3406 65603
Received on Thu Nov 05 1992 - 02:14:22 CST

Original text of this message

HOME | ASK QUESTION | ADD INFO | SEARCH | E-MAIL US