Home » Server Options » Data Guard » RFS request version mismatch
RFS request version mismatch [message #168364] Thu, 20 April 2006 01:20 Go to next message
skarimi
Messages: 8
Registered: March 2006
Location: Australia
Junior Member
hi,

i got a primary database on a machine where the oracle database version is 10.1.0.3.0.
i've created a standby on a machine where theoracle database software is 10.2.0.1.0.

i've changed the compatible parameter to 10.1.0.3.0 (same as primary DB compatible parameter) in the standby pfile. i was able to mount and start the recovery process. i did a switch log on the primary and checked the status and error columns from v$archive_dest and it showed status error and error given was ORA-16039: RFS request version mismatch.

Is it possible to have such a data guard configuration with different DB software versions?
if so how to resolve the above issue of version mismatch?

Thank you.
Re: RFS request version mismatch [message #168410 is a reply to message #168364] Thu, 20 April 2006 04:45 Go to previous message
Frank Naude
Messages: 4565
Registered: April 1998
Senior Member
No, they need to be on the same database version:

$ oerr ora 16039
16039, 00000, "RFS request version mismatch"
// *Cause:  A request to archive a redo log to a standby site failed
//          because the request was incompatible with the Remote File
//          Server (RFS) at the standby site.
// *Action: Verify that compatible versions of Oracle are running on
//          the primary and all standby sites.

Previous Topic: 10g Data Guard Observer
Next Topic: aplly logs
Goto Forum:
  


Current Time: Wed Sep 30 02:00:06 CDT 2020