Home » SQL & PL/SQL » SQL & PL/SQL » EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error (Oracle R12)
EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656261] Fri, 30 September 2016 12:37 Go to next message
ajayhareesh
Messages: 17
Registered: September 2016
Junior Member
Hi,

I'm getting below error while trying to update description for an item.

Entity: ITEM_USER_ATTRS_ENTITY_CODE. Row Identifier: -1. Table Name: EGO_ITM_USR_ATTR_INTRFC.
Unexpected error in EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data: ORA-01403: no data found

Can someone help me understand what exactly is the issue.


Thanks,
Ajay
Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656262 is a reply to message #656261] Fri, 30 September 2016 12:40 Go to previous messageGo to next message
BlackSwan
Messages: 26183
Registered: January 2009
Location: SoCal
Senior Member
01403, 00000, "no data found"
// *Cause: No data was found from the objects.
// *Action: There was no data from the objects which may be due to end of fetch.

The short answer is the error is throw due to bug in application software.

Please read and follow the forum guidelines, to enable us to help you:
OraFAQ Forum Guide
How to use {code} tags and make your code easier to read
Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656263 is a reply to message #656262] Fri, 30 September 2016 12:43 Go to previous messageGo to next message
ajayhareesh
Messages: 17
Registered: September 2016
Junior Member
Hello BlackSwan,

Hope you are doing good. Thank you for the quick reply.

The Item for which I'm trying to update Description, exist in the system. And I'm getting this error only for few items and not for all.


Thanks,
Ajay
Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656266 is a reply to message #656263] Fri, 30 September 2016 14:40 Go to previous messageGo to next message
Michel Cadot
Messages: 65832
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Trust Oracle, if it says there is no data then there is no data... or your query is wrong and does not do what you think it does.

Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656269 is a reply to message #656263] Fri, 30 September 2016 14:51 Go to previous messageGo to next message
BlackSwan
Messages: 26183
Registered: January 2009
Location: SoCal
Senior Member
ajayhareesh wrote on Fri, 30 September 2016 10:43
Hello BlackSwan,

Hope you are doing good. Thank you for the quick reply.

The Item for which I'm trying to update Description, exist in the system. And I'm getting this error only for few items and not for all.

Either you are correct & Oracle is in error
or
Oracle is correct & you are in error.

I know Oracle reports reality than you.

You have to pick between 1 of two alternatives.
1) Find & fix the bug in the application
2) Submit Bug Report to Oracle with a reproducible test case that proves Oracle wrongly reports error.

We can't assist with either path you choose.
Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656271 is a reply to message #656269] Fri, 30 September 2016 16:15 Go to previous messageGo to next message
ajayhareesh
Messages: 17
Registered: September 2016
Junior Member
OK, let's say Oracle is correct. Will API store error messages of previous item when running for next item?

On analyzing, I do see that one item did not exist. For all the items after that, API is still holding the same error message even if the items exist...


Thanks,
Ajay
Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656272 is a reply to message #656271] Fri, 30 September 2016 17:06 Go to previous messageGo to next message
ajayhareesh
Messages: 17
Registered: September 2016
Junior Member
After using "fnd_msg_pub.delete_msg (NULL);" I am not seeing the issue Smile


Thanks,
Ajay
Re: EGO_ITEM_USER_ATTRS_CP_PUB.Process_Item_User_Attrs_Data API Error [message #656335 is a reply to message #656272] Mon, 03 October 2016 08:03 Go to previous message
Bill B
Messages: 1799
Registered: December 2004
Senior Member
what is the update statement that you are trying to do? The error indicates that a select found no rows when it tried to read from a table.
Previous Topic: How to get rolling week count
Next Topic: Get the deletion date for a certain DB object (Stored Procedure)
Goto Forum:
  


Current Time: Tue Oct 16 03:10:54 CDT 2018