Home » RDBMS Server » Server Administration » Do I need to remove OLAP components (11.2.0.1, SLES SP 1)
Do I need to remove OLAP components [message #652743] Fri, 17 June 2016 10:05 Go to next message
juniordbanewbie
Messages: 201
Registered: April 2014
Senior Member
Dear all,

I upgrading from 11.2.0.1 to 11.2.0.4 SE

first time I run utlu112i_11204_009 every thing is fine

**********************************************************************                              
Components: [The following database components will be upgraded or installed]                       
**********************************************************************                              
--> Oracle Catalog Views         [upgrade]  VALID                                                   
--> Oracle Packages and Types    [upgrade]  VALID                                                   
--> JServer JAVA Virtual Machine [upgrade]  VALID                                                   
--> Oracle XDK for Java          [upgrade]  VALID                                                   
--> Oracle Workspace Manager     [upgrade]  VALID                                                   
--> OLAP Analytic Workspace      [upgrade]  VALID                                                   
--> OLAP Catalog                 [upgrade]  VALID                                                   
--> EM Repository                [upgrade]  VALID                                                   
--> Oracle Text                  [upgrade]  VALID                                                   
--> Oracle XML Database          [upgrade]  VALID                                                   
--> Oracle Java Packages         [upgrade]  VALID                                                   
--> Oracle interMedia            [upgrade]  VALID                                                   
--> Spatial                      [upgrade]  VALID                                                   
--> Expression Filter            [upgrade]  VALID                                                   
--> Rule Manager                 [upgrade]  VALID                                                   
--> Oracle Application Express   [upgrade]  VALID                                                   
... APEX will only be upgraded if the version of APEX in                                            
... the target Oracle home is higher than the current one.                                          
--> Oracle OLAP API              [upgrade]  VALID                                                   
.                                                                                                   
**********************************************************************                              
Miscellaneous Warnings                                                                              
<Note: Section can be empty if no such warnings are found.>                                         
**********************************************************************                              
WARNING: --> Database is using a timezone file older than version 14.                               
.... After the release migration, it is recommended that DBMS_DST package                           
.... be used to upgrade the 11.2.0.1.0 database timezone version                                    
.... to the latest version which comes with the new release.                                        
WARNING: --> Your recycle bin contains 6 object(s).                                                 
.... It is REQUIRED that the recycle bin is empty prior to upgrading                                
.... your database.  The command:                                                                   
        PURGE DBA_RECYCLEBIN                                                                        
.... must be executed immediately prior to executing your upgrade.                                  
WARNING: --> Database contains schemas with objects dependent on DBMS_LDAP package.                 
.... Refer to the 11g Upgrade Guide for instructions to configure Network ACLs.                     
.... USER APEX_030200 has dependent objects.                                                        
.                                                                                                   
**********************************************************************                              
Recommendations                                                                                     
**********************************************************************                              
Oracle recommends gathering dictionary statistics prior to                                          
upgrading the database.                                                                             
To gather dictionary statistics execute the following command                                       
while connected as SYSDBA:                                                                          
                                                                                                    
    EXECUTE dbms_stats.gather_dictionary_stats;                                                     
                                                                                                    
**********************************************************************                              
14-JUN-16 01.13.47.901877 AM +02:00                                                                 



but when i run utu112i_11204_009.sql a second time 1 days later, invalid OLAP components


**********************************************************************                              
Components: [The following database components will be upgraded or installed]                       
**********************************************************************                              
--> Oracle Catalog Views         [upgrade]  VALID                                                   
--> Oracle Packages and Types    [upgrade]  VALID                                                   
--> JServer JAVA Virtual Machine [upgrade]  VALID                                                   
--> Oracle XDK for Java          [upgrade]  VALID                                                   
--> Oracle Workspace Manager     [upgrade]  VALID                                                   
--> OLAP Analytic Workspace      [upgrade]  INVALID                                                 
--> OLAP Catalog                 [upgrade]  INVALID                                                 
--> EM Repository                [upgrade]  VALID                                                   
--> Oracle Text                  [upgrade]  VALID                                                   
--> Oracle XML Database          [upgrade]  VALID                                                   
--> Oracle Java Packages         [upgrade]  VALID                                                   
--> Oracle interMedia            [upgrade]  VALID                                                   
--> Spatial                      [upgrade]  VALID                                                   
--> Expression Filter            [upgrade]  VALID                                                   
--> Rule Manager                 [upgrade]  VALID                                                   
--> Oracle Application Express   [upgrade]  VALID                                                   
... APEX will only be upgraded if the version of APEX in                                            
... the target Oracle home is higher than the current one.                                          
--> Oracle OLAP API              [upgrade]  INVALID                                                 
.                                                                                                   
**********************************************************************                              
Miscellaneous Warnings                                                                              
<Note: Section can be empty if no such warnings are found.>                                         
**********************************************************************                              
WARNING: --> Database is using a timezone file older than version 14.                               
.... After the release migration, it is recommended that DBMS_DST package                           
.... be used to upgrade the 11.2.0.1.0 database timezone version                                    
.... to the latest version which comes with the new release.                                        
WARNING: --> Your recycle bin is turned on and currently contains no objects.                       
.... Because it is REQUIRED that the recycle bin be empty prior to upgrading                        
.... and your recycle bin is turned on, you may need to execute the command:                        
        PURGE DBA_RECYCLEBIN                                                                        
.... prior to executing your upgrade to confirm the recycle bin is empty.                           
WARNING: --> Database contains schemas with objects dependent on DBMS_LDAP package.                 
.... Refer to the 11g Upgrade Guide for instructions to configure Network ACLs.                     
.... USER APEX_030200 has dependent objects.                                                        
.                                                                                                   
**********************************************************************                              
Recommendations                                                                                     
**********************************************************************                              
Oracle recommends gathering dictionary statistics prior to                                          
upgrading the database.                                                                             
To gather dictionary statistics execute the following command                                       
while connected as SYSDBA:                                                                          
                                                                                                    
    EXECUTE dbms_stats.gather_dictionary_stats;                                                     
                                                                                                    
**********************************************************************                              
15-JUN-16 08.14.15.792688 AM +02:00                                                                 


on the contrary there is no rows in registry$sys_inv_objs;
select * FROM  registry$sys_inv_objs;

no rows selected


should I remove OLAP compoents? thanks
Re: Do I need to remove OLAP components [message #652744 is a reply to message #652743] Fri, 17 June 2016 10:27 Go to previous message
John Watson
Messages: 7265
Registered: January 2010
Location: Global Village
Senior Member
The database was probably created from a supplied template that included OLAP. If you haven't licensed OLAP, you really shouldn't do that. However, I wouldn't think that Oracle is going to bust you for it. I would remove OLAP, but that is only because I have a very anal attitude towards this sort of thing. You can leave it there, it won't do any harm.
Previous Topic: Confusion Over MOS Certification Matrix and Supported Distribution Documentation
Next Topic: is there a way to install WMSYS in Oracle XE 11.2.0.2
Goto Forum:
  


Current Time: Sat Feb 24 23:52:21 CST 2018

Total time taken to generate the page: 0.11022 seconds