Home » RDBMS Server » Performance Tuning » performance issue with sql query in UAT, But good in local
performance issue with sql query in UAT, But good in local [message #629268] Fri, 05 December 2014 03:07 Go to next message
raja.i
Messages: 11
Registered: November 2014
Junior Member
Actually single table shows {local db(4483 rows),UAT Database(6284 rows)} an issue by degrading performance,
as it is not be applied with index properly in UAT database, but working good in Local database. i just checked with indexes, hints, stastics.
but still it doesn't show any improvement in my UAT environment. As i'm in developer level, what are the parameters,
i have to check in DB to match atleast good performance in UAT like local DB. Please give some useful suggestion.
Thanks.
Re: performance issue with sql query in UAT, But good in local [message #629269 is a reply to message #629268] Fri, 05 December 2014 03:30 Go to previous messageGo to next message
John Watson
Messages: 7220
Registered: January 2010
Location: Global Village
Senior Member
Performance is an attribute of a query, not of a table. You need to read and follow this,
http://www.orafaq.com/forum/mv/msg/84315/433888/#msg_433888
then perhaps someone can advise.
Re: performance issue with sql query in UAT, But good in local [message #629270 is a reply to message #629269] Fri, 05 December 2014 03:45 Go to previous message
cookiemonster
Messages: 12992
Registered: September 2008
Location: Rainy Manchester
Senior Member
And generally speaking the difference in time for oracle to search 4483 rows vs 6284 rows should be a small fraction of a second, with or without indexes. So something else must be going on.
Read the link John posted and supply more information.
Previous Topic: Has anyone ever seen BEGIN_OUTLINE_DATA alone change a plan
Next Topic: tuning basics
Goto Forum:
  


Current Time: Sat Jan 20 14:18:34 CST 2018

Total time taken to generate the page: 0.01211 seconds