Home » RDBMS Server » Server Administration » ORA-02019 (oracle 12c - Windows server 2012)
ORA-02019 [message #617634] Wed, 02 July 2014 07:00 Go to next message
muktha_22
Messages: 526
Registered: December 2009
Senior Member
Hi,

Need a help on the below issue.

We have made two DB link in a same server to a same target database.
Every thing is same, except the "DB LINK NAME'.

But only one is working another one is giving back the below error message.

"ora-02019 connection description for remote database not found".

Regards
Muktha
Re: ORA-02019 [message #617636 is a reply to message #617634] Wed, 02 July 2014 07:17 Go to previous messageGo to next message
Lalit Kumar B
Messages: 3123
Registered: May 2013
Location: World Wide on the Web
Senior Member
There is not much information provided by you so I could only make a guess. What type of dblink is it? Private or Public? If it is private then only the owner of the private database link in the schema can use this link to access database objects in the corresponding remote database. You can read more about it here http://docs.oracle.com/cd/B28359_01/server.111/b28310/ds_concepts002.htm#i1007888.
Re: ORA-02019 [message #617645 is a reply to message #617634] Wed, 02 July 2014 08:23 Go to previous messageGo to next message
Michel Cadot
Messages: 65389
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

ORA-02019:	connection description for remote database not found
Cause:	An attempt was made to connect or log in to a remote database using a
        connection description that could not be found.
Action:	Specify an existing database link. Query the data dictionary to see 
        all existing database links. See your operating system-specific Net8 
        documentation for valid connection descriptors. 
Re: ORA-02019 [message #617646 is a reply to message #617645] Wed, 02 July 2014 08:34 Go to previous messageGo to next message
BlackSwan
Messages: 25858
Registered: January 2009
Location: SoCal
Senior Member
Please read and follow the forum guidelines, to enable us to help you:

http://www.orafaq.com/forum/t/88153/0/ and please read http://www.orafaq.com/forum/t/174502/102589/
Re: ORA-02019 [message #617716 is a reply to message #617646] Wed, 02 July 2014 22:48 Go to previous messageGo to next message
muktha_22
Messages: 526
Registered: December 2009
Senior Member
Hi All,


Thanks for your replies,

Everything is same for both of the link.
And the link made is as a PRIVATE.

Thanks and Regards
Muktha
Re: ORA-02019 [message #617717 is a reply to message #617716] Wed, 02 July 2014 22:57 Go to previous message
BlackSwan
Messages: 25858
Registered: January 2009
Location: SoCal
Senior Member
>Everything is same for both of the link.

same inputs produce same results.
when different results occur, it means inputs are different.

Since you have provided only a recount what you saw, we can't start to guess where the difference exists.
Previous Topic: Upgraded Oracle from 11.2.0.1 to 11.2.0.3 using DBUCA, alert_sid.log doesn't move to new home
Next Topic: rebuild index
Goto Forum:
  


Current Time: Sat Feb 24 23:50:15 CST 2018

Total time taken to generate the page: 0.24577 seconds