Home » RDBMS Server » Server Utilities » EXP/IMP Fail
EXP/IMP Fail [message #528257] Sun, 23 October 2011 23:16 Go to next message
oracle@learner
Messages: 71
Registered: October 2011
Member

I am not able to exp/imp .dmp file. Thanks you in advance.
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Administrator>d:

D:\>imp

Import: Release 10.2.0.1.0 - Production on Mon Oct 24 08:45:48 2011

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

Username: tiger
Password:

IMP-00058: ORACLE error 12560 encountered
ORA-12560: TNS:protocol adapter error
IMP-00000: Import terminated unsuccessfully

  
D:\>imp tiger/tiger@orclimpl full=y ignore=y file=tiger.d
mp log=tiger.log fromuser=tiger touser=abc

Import: Release 10.2.0.1.0 - Production on Mon Oct 24 09:25:30 2011

Copyright (c) 1982, 2005, Oracle.  All rights reserved.


IMP-00058: ORACLE error 12154 encountered
ORA-12154: TNS:could not resolve the connect identifier specified
IMP-00000: Import terminated unsuccessfully

D:\>


Please help me.
Re: EXP/IMP Fail [message #528259 is a reply to message #528257] Sun, 23 October 2011 23:23 Go to previous messageGo to next message
BlackSwan
Messages: 26659
Registered: January 2009
Location: SoCal
Senior Member
>IMP-00058: ORACLE error 12560 encountered
>ORA-12560: TNS:protocol adapter error
>IMP-00000: Import terminated unsuccessfully

throwing these errors when attempting to connect to local DB
indicates OS/Networking/environment is mis-configured.

root cause of problem & fix are external to Oracle

when did this last work without error?
What changed?

Re: EXP/IMP Fail [message #528260 is a reply to message #528259] Sun, 23 October 2011 23:39 Go to previous messageGo to next message
oracle@learner
Messages: 71
Registered: October 2011
Member

Last time , I have changed the workgroup to domain again then Domain to workgroup again. After tha I was not not able to connect database, but with the help from ORAFAQ,Problem was solved. Now this is the new problem for exp and imp.
Re: EXP/IMP Fail [message #528261 is a reply to message #528260] Sun, 23 October 2011 23:41 Go to previous messageGo to next message
BlackSwan
Messages: 26659
Registered: January 2009
Location: SoCal
Senior Member
so why do you keep changing & breaking thing?
Re: EXP/IMP Fail [message #528265 is a reply to message #528261] Sun, 23 October 2011 23:55 Go to previous messageGo to next message
oracle@learner
Messages: 71
Registered: October 2011
Member

to activate Active Directory. Please help me.
Re: EXP/IMP Fail [message #528273 is a reply to message #528265] Mon, 24 October 2011 01:16 Go to previous messageGo to next message
Michel Cadot
Messages: 66875
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
ORA-12560: TNS:protocol adapter error

The database is local to the machine you try to execute this command and your ORACLE_SID is not set.

Quote:
ORA-12154: TNS:could not resolve the connect identifier specified

The database is remote from the machine you try to execute this command and your tnsname.ora does not know the entry you gave (orclimpl)

In first case, set ORACLE_SID; in latter one, add the entry in your tnsnames.ora (and check there is a listener on database server).

Regards
Michel
Re: EXP/IMP Fail [message #528298 is a reply to message #528273] Mon, 24 October 2011 03:18 Go to previous messageGo to next message
oracle@learner
Messages: 71
Registered: October 2011
Member

Its working fine now. How to set default database that imported successfully.
Re: EXP/IMP Fail [message #528302 is a reply to message #528298] Mon, 24 October 2011 03:38 Go to previous messageGo to next message
Michel Cadot
Messages: 66875
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Explain your question.

Regards
Michel
Re: EXP/IMP Fail [message #528312 is a reply to message #528302] Mon, 24 October 2011 04:24 Go to previous messageGo to next message
oracle@learner
Messages: 71
Registered: October 2011
Member

After successfully imported database, when I run application to connect the database is taking the old database exist, but when I checked it with OracleToad new imported is showing and can access from SQL query.

[Updated on: Mon, 24 October 2011 04:25]

Report message to a moderator

Re: EXP/IMP Fail [message #528313 is a reply to message #528312] Mon, 24 October 2011 04:32 Go to previous messageGo to next message
Michel Cadot
Messages: 66875
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Check your connection strings and their parameters (tnsnames.ora entry) in both cases.

Regards
Michel
Re: EXP/IMP Fail [message #528483 is a reply to message #528313] Tue, 25 October 2011 04:55 Go to previous message
oracle@learner
Messages: 71
Registered: October 2011
Member

Its working fine now. Thanks Michel.
Previous Topic: EXP-00026: conflicting modes specified
Next Topic: tool to create CTL file?
Goto Forum:
  


Current Time: Sat Feb 29 07:11:19 CST 2020