Home » Server Options » Data Guard » Does not run standby database (Oracle 11R1 , WinXP)
icon5.gif  Does not run standby database [message #488323] Thu, 06 January 2011 06:47 Go to next message
Tlg13team
Messages: 100
Registered: June 2008
Location: MGL
Senior Member
hi all,

I would like to prepare data guard in Oracle 11R1 on Windows XP.
I using instruction below:
http://www.orafaq.com/node/2030

I did all configuration on the both server.

I execute query below on both server, but not any result on the standby server.

Quote:

select * from v$archived_log


How to check all configuration is correct on both server?
What is wrong I do?

I run "alter system switch logfile" command on primary server, but result same.
Re: Does not run standby database [message #488338 is a reply to message #488323] Thu, 06 January 2011 09:15 Go to previous messageGo to next message
BlackSwan
Messages: 26730
Registered: January 2009
Location: SoCal
Senior Member
what clues exist with alert_SID.log file on both PRIMARY & STANDBY

if/when redo log files are NOT moved between systems then errors will be reported.
Re: Does not run standby database [message #488400 is a reply to message #488338] Fri, 07 January 2011 02:28 Go to previous messageGo to next message
Tlg13team
Messages: 100
Registered: June 2008
Location: MGL
Senior Member
tnsnames.ora file On the Primary:
Quote:

PRIM =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = 172.30.14.240)(PORT = 1521))
)
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = PRIM)
)
)

STAN =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = 172.30.14.130)(PORT = 1521))
)
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = STAN)
)
)


listener.ora file on the Primary side.
Quote:

LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = 172.30.14.240)(PORT = 1521))
)
)


SID_LIST_LISTENER=
(SID_LIST=
(SID_DESC=
(GLOBAL_DBNAME=PRIM_HOST)
(ORACLE_HOME=C:\app\Administrator\product\11.1.0\db_1)
(SID_NAME=PRIM))
(SID_DESC=
(SID_NAME=PRIM)
(GLOBAL_DBNAME=PRIM)
(ORACLE_HOME=C:\app\Administrator\product\11.1.0\db_1)))


tnsnames.ora file on the Standby site
Quote:

STAN =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = 172.30.14.130)(PORT = 1521))
)
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = STAN)
)
)


PRIM =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = 172.30.14.240)(PORT = 1521))
)
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = PRIM)
)
)



listener.ora file on the standby site
Quote:

LISTENER =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = hugo2)(PORT = 1521))
)

SID_LIST_LISTENER=
(SID_LIST=
(SID_DESC=
(SID_NAME=STAN)
(ORACLE_HOME=C:\app\Administrator\product\11.1.0\db_1)))



ALERT.LOG ON THE PRIMARY SITE
Quote:

Fri Jan 07 14:38:04 2011
Error 12154 received logging on to the standby
Errors in file c:\app\administrator\diag\rdbms\prim\prim\trace\prim_arcr_2076.trc:
ORA-12154: TNS:could not resolve the connect identifier specified
PING[ARCr]: Heartbeat failed to connect to standby 'STAN'. Error is 12154.
Fri Jan 07 14:43:57 2011
Error 12154 received logging on to the standby
Errors in file c:\app\administrator\diag\rdbms\prim\prim\trace\prim_arcr_2076.trc:
ORA-12154: TNS:could not resolve the connect identifier specified
PING[ARCr]: Heartbeat failed to connect to standby 'STAN'. Error is 12154.
Fri Jan 07 15:44:13 2011


***********************************************************************

Fatal NI connect error 12170.

VERSION INFORMATION:
TNS for 32-bit Windows: Version 11.1.0.6.0 - Production
Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 11.1.0.6.0 - Production
Windows NT TCP/IP NT Protocol Adapter for 32-bit Windows: Version 11.1.0.6.0 - Production
Time: 07-JAN-2011 15:44:13
Tracing not turned on.
Tns error struct:
ns main err code: 12535

TNS-12535: TNS:operation timed out
ns secondary err code: 12606
nt main err code: 0
nt secondary err code: 0
nt OS err code: 0
Client address: (ADDRESS=(PROTOCOL=tcp)(HOST=172.30.14.240)(PORT=1667))
WARNING: inbound connection timed out (ORA-3136)
Fri Jan 07 15:54:11 2011
LNS1 started with pid=18, OS id=1560
Fri Jan 07 15:54:15 2011
Thread 1 advanced to log sequence 55
Current log# 1 seq# 55 mem# 0: C:\APP\ADMINISTRATOR\ORADATA\PRIM\REDO01.LOG
LNS: Standby redo logfile selected for thread 1 sequence 55 for destination LOG_ARCHIVE_DEST_2
Fri Jan 07 15:54:17 2011
ARC4: Standby redo logfile selected for thread 1 sequence 54 for destination LOG_ARCHIVE_DEST_2



TRACE file on the Primary site:
Quote:

*** 2011-01-07 15:54:17.170
*** SESSION ID:(149.1) 2011-01-07 15:54:17.170
*** CLIENT ID:() 2011-01-07 15:54:17.170
*** SERVICE NAME:(SYS$BACKGROUND) 2011-01-07 15:54:17.170
*** MODULE NAME:() 2011-01-07 15:54:17.170
*** ACTION NAME:() 2011-01-07 15:54:17.170

Redo shipping client performing standby login
OCISessionBegin failed. Error -1
.. Detailed OCI error val is 1017 and errmsg is 'ORA-01017: invalid username/password; logon denied
'
An attempt to establish secure session using password verifier based approach will be attempted..
OCISessionBegin failed. Error -1
.. Detailed OCI error val is 1031 and errmsg is 'ORA-01031: insufficient privileges
'
An attempt to establish secure session using password verifier based approach will be attempted..
*** 2011-01-07 15:54:17.373 4025 krsu.c
Logged on to standby successfully
Client logon and security negotiation successful!



What is wrong?
Re: Does not run standby database [message #488406 is a reply to message #488323] Fri, 07 January 2011 04:04 Go to previous messageGo to next message
Tlg13team
Messages: 100
Registered: June 2008
Location: MGL
Senior Member
I found a solution from URL below:
Quote:

http://jhdba.wordpress.com/2008/05/12/more-problems-with-orapwd-file-and-shipping-redo-logs/


Let me explain this issue:
Ever configuration is OK on both database, but do not run my data guard configuration. The primary database can copy archive log files to Standby database but can not apply log file on Standby database!

Solution:
Just recreate password file second time on Primary server and copy it to Standby server. Restart both databases after working...

When fix this bug the Oracle?
Re: Does not run standby database [message #488463 is a reply to message #488406] Fri, 07 January 2011 09:24 Go to previous messageGo to next message
BlackSwan
Messages: 26730
Registered: January 2009
Location: SoCal
Senior Member
>When fix this bug the Oracle?
Not a bug.
Problem Exists Between Keyboard And Chair.
Oracle RDBMS has NO control over external OS files like the password file.
Re: Does not run standby database [message #489051 is a reply to message #488463] Thu, 13 January 2011 01:59 Go to previous message
Tlg13team
Messages: 100
Registered: June 2008
Location: MGL
Senior Member
Hi BlackSwan

Sorry, your comment not clear for me.
please little more explain.
Previous Topic: Data Guard failover steps (4 threads merged by bb)
Next Topic: Resources of data Guard
Goto Forum:
  


Current Time: Tue Aug 11 16:53:25 CDT 2020