Home » Server Options » Spatial » ORA-29855 (Oracle Database 10g Enterprise Edition Release - 64bi)
ORA-29855 [message #357706] Thu, 06 November 2008 05:27 Go to next message
Messages: 573
Registered: February 2008
Senior Member
Hi experts,

did IMP an user with some spatial tables.
Got error 29855 (german) for each table, like this:
IMP-00017: Nachfolgende Anweisung war wegen Oracle-Fehler 29855 erfolglos:
IMP-00003: ORACLE-Fehler 29855 aufgetreten
ORA-29855: Fehler bei Ausf³hrung der Routine ODCIINDEXCREATE
ORA-13282: Initialisierung von Koordinatentransformation nicht erfolgreich
ORA-06512: in "MDSYS.SDO_INDEX_METHOD_10I", Zeile 10

Get exactly the same error, when I try to build the index afterwards in SQL.

The Metadatatable seems ok to me:
 where sdo_table_name in ('AUSGESTALTUNG_L')

ALK_IMP   AUSGESTALTUNG_L LINEGEOM        ((X; 2500000; 3700000; 0,001); (Y; 5600000; 5900000; 0,001); ; ) 25833

The coord.system 25833 is in the SDO_COORD_REF_SYS and SDO_COORD_SYS too.

Help is very appreciated.
Re: ORA-29855 [message #358261 is a reply to message #357706] Mon, 10 November 2008 06:31 Go to previous messageGo to next message
Messages: 573
Registered: February 2008
Senior Member
Solved the problem Razz

It seems to be a problem with NLS in the oracle spatial cartdridge.
Had to replace ',' with '.' in the numeric valaues of the table MDSYS.SDO_CS_SRS, although we use german NLS settings.
Re: ORA-29855 [message #358866 is a reply to message #357706] Wed, 12 November 2008 14:35 Go to previous message
Messages: 5
Registered: October 2008
Location: Nashua, NH
Junior Member
The German decimal comma issue is described in bug 5097326. It was fixed, in February 2007, backported to a patch, in March 2007, and already fixed in the release.
The bug page also documents a workaround.

You may want to upgrade to a more recent patch level.

Sorry for the inconvenience thanks,

Previous Topic: ORA-29532
Next Topic: SDO_RELATE
Goto Forum:

Current Time: Fri May 07 15:38:11 CDT 2021