RAC error: Error 0(Native: listNetInterfaces:[3]) vipca --Help?

From: laura pena <lizzpenaorclgrp_at_yahoo.com>
Date: Sun, 10 Jan 2010 11:44:27 -0800 (PST)
Message-ID: <325416.20131.qm_at_web58204.mail.re3.yahoo.com>

Hello - So it has been a long weekend.

First looks like what happened is the ocr file was removed from our 2 node RAC 10g linux cluster. I did create an empty ocr by following metalink: How to Restore CRS after accidentally run localconfig on RAC system [ID 747415.1] This told me to touch a file on the good node and then run ocrconfig -replace ocr  command. Rebooted now it looks like I have the following: olnodes: (good)

crsctl check crs (good)
CSS appears healthy
CRS appears healthy
EVM appears healthy

ps -ef |grep d.bin (good):
root     22235     1  0 01:13 ?        00:00:00 /home/oracle/app/product/10gR2/crs/bin/crsd.bin reboot
oracle   22774 22234  0 01:15 ?        00:00:00 /home/oracle/app/product/10gR2/crs/bin/evmd.bin
oracle   22917 22885  0 01:15 ?        00:00:11 /home/oracle/app/product/10gR2/crs/bin/ocssd.bin


$ORA_CRS_HOME/bin/crs_stat (Not good)
CRS-0202: No resources are registered.

So I go to start vipca and get the following  message:

# vipca
Error 0(Native: listNetInterfaces:[3]) 
[Error 0(Native: listNetInterfaces:[3])]

10gR2 RAC Install issues on Oracle EL5 or RHEL5 or SLES10 (VIPCA / SRVCTL / OUI Failures) [ID 414163.1] I did modify the vipca file and added unset LD_ASSUME_KERNEL  but this sadly did not solve my issue.

Any ideas what the issue could be I'd like to see my databases when I run $ORA_CRS_HOME/bin/crs_stat again.

Thanks in advance for any input.

Received on Sun Jan 10 2010 - 13:44:27 CST

Original text of this message