Re: Error during oracle install

From: David Lord <>
Date: Wed, 21 May 2008 18:49:38 +0100
Message-ID: <>


ld is failing to find the library. So either its not there, which is unlikely as long as you're using the right installation media, or it can't find it because the path its using is messed up. I do a lot of oracle installations and I generally find the best way to proceed is to do exactly what the official docs tell you to do *and no more*, at least in the first instance. They don't tell you to set LD_LIBRARY_PATH or LD_LIBRARY_PATH_64 so why don't you try unsetting them and seeing if it fixes the problem?

David Lord

2008/5/21 Khan, Muhammad S <>:
> Hi David,
> (a) Here are my relevant environment variables:
> MANPATH=/usr/local/man:/usr/bin/man:/usr/share/man:/usr/openwin/man:/usr
> /dt/man
> PATH=/usr/vendor/oracle/client/
> .0.6/Apache/Apache/bin:/usr/vendor/oracle/client/
> al/sbin:/usr/local/bin:/usr/openwin/bin:/usr/lib:/usr/sbin:/usr/bin:/usr
> /ccs/bin:/usr/sadm/admin/bin:/usr/ucb
> ORACLE_BASE=/usr/vendor/oracle
> LIBPATH=/opt/CA/UnicenterSoftwareDelivery/usd/lib:/opt/CA/SharedComponen
> ts/lib
> ORACLE_DOC=/usr/vendor/oracle/client/
> TNS_ADMIN=/usr/vendor/oracle/client/
> LD_LIBRARY_PATH_64=/usr/vendor/oracle/client/
> LD_LIBRARY_PATH=/usr/lib:/usr/openwin/lib:/usr/vendor/oracle/client/9.2.
> 0.6/lib
> ORACLE_HOME=/usr/vendor/oracle/client/
> (b) I'm confused about your opinion of LD_LIBRARY_PATH. I've clearly
> read at many places that it should be set to $ORACLE_HOME/lib to avoid
> any error during install.
> Thanks,
> Khan

Received on Wed May 21 2008 - 12:49:38 CDT

Original text of this message