RAC services unknown after a reboot

From: Best, David <David.Best_at_cognos.com>
Date: Thu, 10 Apr 2008 09:06:33 -0400
Message-ID: <2B4E386EAEC90947802323BF373DC0EC0D593954@sottemail1.ent.ad.cognos.com>

Hey all, after a reboot the only service thats starts properly is the VIP. The rest are online but in an unknown state. I'm using in a vmware sandbox environment.

In my crsd.log file I see alot of time outs as well, with the first one failing ora.<nodename>.ASM1.asm

I have enabled debugging via the service and in racgwrap via the parameter _USR_ORA_DEBUG but my ASM log doesn't even get written to on reboot. A clip of my crsd.log: note: I increased the timeout from 600 to 2000

Attempting to start `ora.raclinux`.ASM`.asm` on member `raclinux` Action Script /home/oracle/product/10.2.0/asm1/bin/racgwrap(start) timed out for ora.raclinux1.ASM1.asm! (timeout=2000) StartResource error for ora.raclinux1.ASM1.asm error code = -2
Action Script /home/oracle/product/10.2.0/asm1/bin/racgwrap(stop) timed out for ora.raclinux1.ASM1.asm! (timeout=2000) StopResource error for ora.raclinux1.ASM1.asm error code = -2 X_OP_StopResourceFailed : Stop resource failed (File: rti.cpp, line: 1698
`ora.raclinux1.ASM1.asm` has experienced an unrecoverable failure Human intervention required to resume its availability.

As soon as I reboot I tail my crsd.log file and within 2 seconds after the start line appears it times out... No where close to 2000 seconds. Also, as I said, none of the asm log files get touched.

If I do a crs_stop all , then crs_start all I get dependency errors on ASM. However, if I shutdown everything (crs_stop -all) and start everything up with srvctl it starts fine. ie.

srvctl start nodeapps -n raclinux1
srvctl start asm -n raclinux1
srvctl start database -d RACDB

everything starts fine.. Any suggestions?

Received on Thu Apr 10 2008 - 08:06:33 CDT

Original text of this message