Oracle FAQ Your Portal to the Oracle Knowledge Grid

Home -> Community -> Mailing Lists -> Oracle-L -> Question re CRS installation and Redhat Linux Versioning

Question re CRS installation and Redhat Linux Versioning

From: William Wagman <>
Date: Wed, 11 Jul 2007 09:03:21 -0700
Message-ID: <>


I realize this is an Oracle list but I am hoping someone may be experienced enough with Linux to assist me here. I am attempting to install CRS on two separate clusters both running RHEL4 and configured identically. I can install CRS successfully but after installation some operations, srvctl stop nodeapps -n <node_name> for example, there are others, cause the CRS to 'hang' on one node. I have an SR open with Oracle (it's been a month now with no resolution) and they are finally coming to questioning the Linux installation which, as I understand it and according to the installation guide, the cluvfy utility and the RDA pre-checks is configured correctly but I am beginning to wonder.

First, The Redhat 4 must also be at RHEL AS/ES 4.0 2.6.9-5.0.5.EL or higher. On my systems uname -a returns... Linux barnaby 2.6.9-55.ELsmp #1 SMP Fri Apr 20 17:03:35 EDT 2007 i686 i686 i386 GNU/Linux?

As to RPMS....
We have binutils- - oracle wants binutils-
We have control-center-2.8.0-12.rhel4.5 - oracle wants control-center-2.8.0-12
We have gcc-3.4.6-8 - oracle wants gcc-3.4.3-9.EL4 We have gcc-c++-3.4.6-8 - oracle wants gcc-c++-3.4.3-9.EL4 We have glibc-2.3.4-2.36 - oracle wants glibc-2.3.4-2 We have glibc-common-2.3.4-2.36 - oracle wants glibc-common-2.3.4-2 We have libstdc++-3.4.6-8 - oracle wants libstdc++-3.4.3-9.EL4 We have libstdc++-devel-3.4.6-8 - oracle wants libstdc++-devel-3.4.3-9.EL4
We have make-3.80-6.EL4 - oracle wants make-3.80-5 We have pdksh-5.2.14-30.3 - oracle wants pdksh-5.2.14-30 We have sysstat-5.0.5-15.0.1.el4 - oracle wants sysstat-5.0.5-1 We have xscreensaver-4.18-5.rhel4.14 - oracle wants xscreensaver-4.18-5.rhel4.2
We have openmotif21-2.1.30-11.RHEL4.6 - oracle wants openmotif21-2.1.30-11.RHEL4.2 (required to install Oracle demos) We have libaio-0.3.105-2 - oralce wants libaio-0.3.102-1

As I understand it we are compliant. I am also concerned that the analyst working on the SR said "what I am concern is that the some of the packages required ends with EL4. I am not sure what the EL4 means, and I also am not sure what rhel4.5 means for control-center-2.8.0-12.rhel4.5." That comment concerns me a bit, I asked him to verify with someone in the Linux group. In the meantime if someone can confirm for me that we are in fact on a supported version and also answer the questions the analyst proposed I would be most appreciative.


Bill Wagman
Univ. of California at Davis
IET Campus Data Center
(530) 754-6208

Received on Wed Jul 11 2007 - 11:03:21 CDT

Original text of this message