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Oracle 11i Receivables Implementation Primer
®

By Cheetah Solutions
Editor’s Note: The implementation of
Oracle 11i Receivables does not have
to be riddled with showstopper issues
and numerous open TARs. With a
little forward thinking, organization,
and preparation, your project can
roll out successfully. With any Oracle
11i Receivables implementation, it is
pretty much a foregone conclusion
that issues will occur; but the good
news is these issues occur for just
about every Receivables project, are
well documented, and are easily corrected. Cheetah Solutions, a regular
ORAtips contributor, walks the reader through the top ten implementation and testing issues associated
with Oracle 11i Receivables. Now
that’s “thinking Oracle.”

Introduction

This article will focus on the top ten
Oracle 11i Receivables implementation and testing issues, and will provide the steps to take to correct them
before opening an Oracle TAR.
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1. Define

Item Validation
Organization Parameter
Oracle Receivables shares some
common functionality with Oracle Order Management
 he Item Validation OrganizaT
tion parameter must indicate the
operating unit that can be used
for processing orders and returns
if certain order / line attributes
are not entered. Even if you are
not using Order Management or
do not have a multi-organization configuration, this parameter must be defined for Oracle
Receivables to function correctly
as it impacts tax configuration.

 sing the navigation path
U
Oracle Order Management > Order Management Super User > Setup
> Parameters, select Item
Validation Organization
from the list of values
(LOV) and save. Figure 1 Figure 1: FRM-40735 upon Form Save
shows the resulting error
message.
 his is a classic error message
T
throughout an Oracle 11i Receivables implementation. Improper
configuration of this parameter
impacts item selection in the
transaction workbench and tax
configuration, to name a couple.

2. Recompile the AR schema;
repeat until the error record
count drops.
3. Using ADADMIN, recompile
all AR, JTF, and ONT forms
and libraries.

Before opening a Oracle MetaLink TAR, perform the following steps, in order:

4. Manually recompile the Item
Validation Parameter form
and its associated PLS file.

1. Confirm you have selected the
correct Item Validation Organization from the LOV for
your operating unit.

5. Relink the ONT and FND
forms; relink the AR and FND
forms.
6. Execute synonyms.
7. Re-test.

Improper
configuration of this
parameter impacts
item selection in the
transaction workbench and tax
configuration.

ORAtips.com

8. If it still fails, open a SEV 2
ESC TAR, as this is a showstopper for your Receivables
implementation.
9. Oracle Support will respond
by asking you to run the AR
Diagnostics Patch. If you have
not installed this patch, do not
waste your time, as it is not an
easy install, has many prerequisites, and impacts both
your technology stack and
OA framework. Instead, ask
Oracle Support to provide the
SQL scripts that collect the
same data as the Diagnostics
utility.
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2. Define AutoAccounting
You want to take advantage of
AutoAccounting and enter a
constant value for one or more
of your organizations chart of
accounts. Upon save, an error as
shown in Figure 2 appears.
 elieve it or not, the most likely
B
cause for this issue is that the
accounting flexfield segments sequence numbers are defined as
10, 20, 30, 40, etc., instead of 1,
2, 3, 4, etc.
 efore opening a MetaLink TAR,
B
perform the following steps, in
order:
1. Using the navigation path
Oracle System Administrator
> Application > Flexfields >
Key > Segments, query your
accounting flexfield structure.
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2. Change the segment
numbers to one digit
sequential numbers.
3. Save. Freeze and recompile the flexfield
structure.
4. Re-test.
5. If it still fails, open Figure 2: AutoAccounting Error Message
a SEV 2 TAR, as
this is not a showstopper
open the form. Figure 3 displays
for your Receivables implethe result, which is another clasmentation but definitely an
sic error message and one of
inconvenience.
my favorites because even seasoned Oracle consultants, myself
6. Oracle Support will respond by
included, usually forget to do
asking you about your setup,
both steps necessary to prevent
i.e., item validation paramthis error from occurring.
eter, system options, etc.
Before opening a MetaLink TAR,
3. Define Customers
perform the following steps, in
Using the navigation path Oracle
order:
Receivables > Receivables Manager > Customer > Standard,

Figure 3: FRM-40735 upon Open Form
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1. Recompile the Location Flexfield Structure in the System
Options window. Yup, this is a
key flexfield issue.
 sing the navigation path OraU
cle Receivables > Receivables
Manager > Setup > System >
System Options > Tax tab, go
to the Location Flexfield Structure.
Remember when you defined
your Sales Territory Flexfield,
the default “State.County.
City” populated the field and if
that is what you are using, you
accepted it.
 T
 he secret is to de-select, and
then re-select the value from
the LOV, and then save this
form. Doing so kicks off five
concurrent programs called
“Flexfield PL/SQL Pre-Processors.” Ensure your concurrent
manager is running and ensure
these programs all complete
successfully.
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2. Next, re-compile the Sales Tax
Location Flexfield in the Key
Flexfield Segments window.
Using the navigation path Oracle Receivables > Receivables
Manager > Setup > Financials
> Flexfields > Key > Segments,
query the Sales Tax Location
flexfield. Unfreeze, save, refreeze, and compile. This kicks
off two concurrent programs
called “Flexfield View Generator.” Ensure your concurrent
manager is running and ensure
these programs all complete
successfully.
3. Re-test.
4. If it still fails, open a SEV 2
ESC TAR, as this is a showstopper for your Receivables
implementation.
5. Oracle Support will respond
by asking you to run the AR
Diagnostics Patch. If you have
not installed this patch, do not

waste your time, as it is not an
easy install, has many prerequisites, and impacts both
your technology stack and
OA framework. Instead ask
Oracle Support to provide the
SQL scripts that collect the
same data as the Diagnostics
utility.
4. T
 ax Forms (Authorities, Locations, Sales Tax Rates, Exemptions, Exceptions)
So you have jumped ahead and
did not read the first ORAtip,
which was to define the Item Validation Organization Parameter.
Now you have a tax form issue as
shown in Figure 4. Guess what,
even though the error message
tells you to re-compile your
Sales Tax Location flexfield both
as a KFF and System Option,
(and it’s not a bad idea), what
you really need to do is go back
to the first tip and ensure your
Order Management configuration is completed. Tax forms

Figure 4: AR-11254 Error upon Open Form
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depend on this step, and you
cannot open any of the tax forms
until it is properly defined.
Before opening a MetaLink TAR,
perform the following steps, in
order:
1. Using the navigation path
Oracle Order Management
> Order Management Super
User > Setup > Parameters,
ensure you have defined and
saved the Item Validation
Organization Parameter.
2. Next, recompile the Location Flexfield Structure in the
System Options window. Yup,
this is a key flexfield issue.
Using the navigation path
Oracle Receivables > Receivables Manager > Setup > System > System Options > Tax
tab, go to the Location Flexfield Structure.
 emember when you defined
R
your Sales Territory Flexfield,
the default “State.County.
City” populated the field and
if that is what you are using,
you accepted it.
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 he secret is to de-select, and
T
then re-select the value from
the LOV, and then save this
form. Doing so kicks off five
concurrent programs called
“Flexfield PL/SQL Pre-Processors.” Ensure your concurrent manager is running
and ensure these programs all
complete successfully.
3. Next, re-compile the Sales Tax
Location Flexfield in the Key
Flexfield Segments window.

Location flexfield. Unfreeze,
save, re-freeze, and compile.
This kicks off two concurrent
programs called “Flexfield
View Generator.” Ensure your
concurrent manager is running
and ensure these programs all
complete successfully.
4. Re-test.
5. If it still fails, open a SEV 2
ESC TAR, as this is a showstopper for your Receivables
implementation.
6. Oracle Support will respond
by asking you to run the AR
Diagnostics Patch. If you have
not installed this patch, do not
waste your time, as it is not an
easy install, has many prerequisites, and impacts both
your technology stack and
OA framework. Instead ask
Oracle Support to provide the
SQL scripts that collect the
same data as the Diagnostics
utility.

The secret is to
de-select, and then
re-select the value
from the LOV…doing
so kicks off five
concurrent programs
called “Flexfield PL/
SQL Pre-Processors.”

Using the navigation path
Oracle Receivables > Receivables Manager > Setup >
Financials > Flexfield > Key >
Segments, query the Sales Tax

5. Create Transactions
Once customers and customer sites are created and their
relationships defined, it’s time
to start creating transactions.
Unfortunately, your customer
bill-to location is not defaulting
when you select a customer nor
does the bill-to location LOV
contain any values.
 his is another quirky example
T
of contradictions Oracle Receivables introduces. All customers,
regardless of whether you will
be billing them for goods and
services sold and shipped, must
have a primary bill-to location
defined.
 efore opening a MetaLink TAR,
B
perform the following steps, in
order:
1. Using the navigation path
Oracle Receivables > Receivables Manager > Customers >
Standard, query the customer
you were attempting to create
a transaction for.
2. Navigate to the Business Purposes tab and note the usage
setup. Does the customer have
a primary, active bill-to usage
and location defined? If not,
check the primary checkbox.
N
 ote: If your customer has
multiple sites, only one site can
be the primary bill-to site. All
other sites you should mark as
active but not primary. During transaction creation, these
sites will be available to select
from the LOV.
3. Re-test.
4. If it still fails, open a SEV 2
TAR, as this is not a showstopper for your Receivables
implementation but definitely
an inconvenience.
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5. Oracle Support will respond
by asking you to run the AR
Diagnostics Patch. If you have
not installed this patch, do not
waste your time, as it is not an
easy install, has many prerequisites, and impacts both
your technology stack and
OA framework. Instead, ask
Oracle Support to provide the
SQL scripts that collect the
same data as the Diagnostics
utility.
6. C
 reate Transaction Line
Items
Now that the Bill-to and Ship-to
business purposes primary and
active checkboxes have been
enabled for each customer and/
or customer site, you are ready
to proceed with invoice creation.
Unfortunately another problem
surfaces as shown in Figure 5.
 his error has occurred because
T
you have enabled AutoAccounting using the site G/L accounts
to derive the receivables, tax,
or revenue segment informa-
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tion, but you forget to define the
default accounts at the customer
site level.

stopper for your Receivables
implementation but definitely
an inconvenience.

 efore opening a MetaLink TAR,
B
perform the following steps, in
order:

5.  Oracle Support will respond
by asking you to run the AR
Diagnostics Patch. If you have
not installed this patch, do not
waste your time, as it is not
an easy install, has many prerequisites, and impacts both
your technology stack and OA
framework. Instead ask Oracle
Support to provide the SQL
scripts that collect the same
data as the Diagnostics utility.

1. Using the navigation path
Oracle Receivables > Receivables Manager > Customers >
Standard, query the customer
you were attempting to create
a transaction for.
2. Navigate to the Business
Purposes tab and open the
Bill-to usage. Navigate to the
Accounts tab and enter receivable, revenue, and tax code
combinations. Save.
N
 ote: If your customer has
multiple sites, repeat for every
site.
3. Re-test.
4. If it still fails, open a SEV 2
TAR, as this is not a show-

7. Complete Transactions
Congratulations, you have created and saved your first transaction. Having read the Oracle
11i Receivables User Guide, you
know you need to complete the
transaction if you want to print it,
post it, or have it appear on your
aging reports. You click the Complete button. Nothing happens,
but the message at the bottom
of your window said one record
saved and completed. But, wait a

Figure 5: Transaction Workbench AutoAccounting Error
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minute, should not the Complete
checkbox in the upper-right corner of the transaction workbench
window be checked and should
not the Complete button now be
the Incomplete button. You click
again, and click again, and still
the message tells you one record
saved and completed. Oops.
This is a tricky issue that requires
your Oracle Database Administrator involvement. The transaction workbench form and its
associated libraries require recompiling.
 efore opening an Oracle MetB
aLink TAR, perform the following steps, in order:
1. Recompile the AR schema;
repeat until the error record
count drops.
2. Using ADADMIN, recompile
all AR, and JTF forms and
libraries.
3. Manually recompile the transaction workbench form (ARXTWMAI) and its associated
PLS file.
4. Relink the AR and FND
forms.
5. Execute synonyms.
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waste your time, as it is not an
easy install, has many prerequisites, and impacts both
your technology stack and
OA framework. Instead ask
Oracle Support to provide the
SQL scripts that collect the
same data as the Diagnostics
utility.
 ip: This solution will also
T
resolve two other classic
issues: creating and completing Credit Memos and selecting items or descriptions
(standard memo lines) during
invoice creation.

 efore opening a MetaLink TAR,
B
perform the following steps, in
order:

The AR Diagnostics
Patch is an
excellent utility
but it does impact
both the technology
stack and OA
framework.

6. Re-test.
7. If it still fails, open a SEV 2
ESC TAR, as this is a showstopper for your Receivables
implementation.
8. Oracle Support will respond
by asking you to run the AR
Diagnostics Patch. If you have
not installed this patch, do not

monitor the concurrent manager.
Shortly thereafter, the program
completes with error, as shown
in Figure 6, and the first stage in
the request set Revenue Recognition completes with warning.
What happened? A quick glance
at the log file tells little but does
include a cryptic error message. Like any good Oracle user,
you type the error message into
MetaLink’s search engine, which
quickly returns with a solution.
The print option for the Revenue
Recognition concurrent program
is enabled, which causes the
General Ledger Transfer process
to fail.

8. I nterface to General Ledger
Transactions are entered, receipts
applied, you are ready to post to
the General Ledger. Using the
navigation path, you submit the
General Ledger Transfer process
and click on View > Requests to

1. Using the navigation path
Oracle System Administrator
> Concurrent > Programs >
Define, query the concurrent
program “Revenue Recognition.” Scroll down to the one
that has ARBARL_NON_SRS
as its shortname.
2. Disable the print option and
save.
3. Re-test.
4. If it still fails, open a SEV 2
ESC TAR, as this is a showstopper for your Receivables
implementation.
5. Oracle Support will respond
by asking you for concurrent
program version information,
which you can find by using
the UNIX command grep to
find the report header.

Figure 6: Concurrent Manager View Requests
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9. Print Invoices
The next logical step in using
Oracle 11i Receivables is printing customer invoices. You navigate to the Invoices sub-function,
enter the concurrent program
parameter information, and submit the request. Using the View
> Requests menu, you watch
your concurrent program complete successfully and even view
the output on screen. You go to
the printer where a pile of blank
paper greets you. Not what you
were expecting.
 his is another tricky issue
T
that is easily resolved with the
help of your Oracle System
Administrator.
 efore opening a MetaLink TAR,
B
perform the following steps, in
order:
1. Using the navigation path
Oracle System Administrator > Concurrent > Programs
> Define, query the executable “Transaction Print.” Five
concurrent programs use this
executable.
2. For each validate, the print
style is Invoice Print and the
print option is enabled.
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3. Next, still within the Oracle
System Administrator responsibility, navigate to Install >
Printer > Register. Query the
name of the printer you will
be using to print invoices, and
document its associated printer type.
4. Next, still within the Oracle
System Administrator respon-

sibility, navigate to Install
> Printer > Type. Query the
type of printer identified in
step 3. Insert a new record,
selecting from the list of values INVOICE as the printer
style and the landscape driver
for your printer. Save.

If you want to

5. Re-test.

suppress the header

6. If it still fails, open a SEV 2
ESC TAR, as this is a showstopper for your Receivables
implementation.

page from printing,
set the default value
for Number of

7. Oracle Support will respond
by asking you to run the AR
Alignment page
Diagnostics Patch. If you have
not installed this patch, do not
to zero.
waste your time, as it is not an
easy install, has many prerequisites and impacts both
your technology stack and
OA framework. Instead ask
Oracle Support to provide the
SQL scripts that collect the
same data as the Diagnostics
utility.
 unning Letters come pre-seeded
D
with bind variables for invoices and
Tip: If you want to suppress collector information. The invoices
the header page from print- will print on the Dunning Letter if
ing, set the default value for you create a message line with the
Number of Alignment page to text “&INVOICE.”
zero. This is a concurrent program parameter for each of
T
 ip: Case is very important and
the concurrent programs that
must be UPPER.
use the executable “transaction print.”
Before opening a MetaLink TAR,
perform the following steps, in
10. Dunning Letters
order:
Custom Dunning Letters are
easy to define, right? So why,
1. Using the navigation path
then, does your Dunning Letter
Oracle Receivables > Receivnot print the customer’s invoice
ables Manager > Setup > Print
information? All the rest of the
Documents > Dunning Letverbiage you entered is there as
ters, query your custom letter.
shown in Figure 7.

Figure 7: Dunning Letter
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2. Position your cursor on the
message line where you
want invoices to print. Enter
&INVOICE. Save.
3. Re-test.
4. If it still fails, open a SEV 2
TAR, as this is not a showstopper for your Receivables
implementation but definitely
an inconvenience.
5. Oracle Support will respond by
asking you about your setup,
i.e., item validation parameter, system options, etc.

Conclusion

And there you have it. The top ten
issues Oracle customers encountered
when first implementing and testing Oracle 11i Receivables. As you
have read, most are easily resolved
with very little assistance from Oracle Support or your technical team.
And following the steps at the time
of implementation rather than waiting to encounter the issue can avert
many.      
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Not all issues are
showstoppers, the
trick is knowing
which ones to
escalate…
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This article was originally published by Klee Associates, Inc., publishers of JDEtips and SAPtips.
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