Home » SQL & PL/SQL » Client Tools » Problem with high ASCII characters in Oracle 11G (Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production)
Problem with high ASCII characters in Oracle 11G [message #643431] Wed, 07 October 2015 08:12 Go to next message
Xandot
Messages: 235
Registered: January 2014
Location: India
Senior Member
Hi All,

We have migrated our 10g application to 11g and in 11G extended special character is not supporting but in 10G its working.

Issue seems like character set is not supported in 11G. All extended characters are not working in 11G.

Above issue is coming because One Function is written in forms level to validate the Special Character(0-127) and Extended special character(start from 128).



Thanks
Xandot
Re: Problem with high ASCII characters in Oracle 11G [message #643434 is a reply to message #643431] Wed, 07 October 2015 08:20 Go to previous messageGo to next message
cookiemonster
Messages: 13017
Registered: September 2008
Location: Rainy Manchester
Senior Member
Is this problem specific to forms or do you get it in sqlplus as well?
Re: Problem with high ASCII characters in Oracle 11G [message #643437 is a reply to message #643434] Wed, 07 October 2015 09:09 Go to previous messageGo to next message
CraigB
Messages: 386
Registered: August 2014
Location: Utah, USA
Senior Member
Can you give us some examples of when it worked and what it does now?
Re: Problem with high ASCII characters in Oracle 11G [message #643438 is a reply to message #643434] Wed, 07 October 2015 09:19 Go to previous messageGo to next message
Xandot
Messages: 235
Registered: January 2014
Location: India
Senior Member
Its not working on sqlplus and forms also.

Example:

select chr(144) from dual;



Its not giving me right output on sqlplus also. ASCII 0-126 range is working properly but after 127-255 not generate output properly.

Please help me out..





Re: Problem with high ASCII characters in Oracle 11G [message #643441 is a reply to message #643438] Wed, 07 October 2015 09:38 Go to previous messageGo to next message
cookiemonster
Messages: 13017
Registered: September 2008
Location: Rainy Manchester
Senior Member
Seems the problem is nothing to do with forms so I've moved the topic to a more suitable forum.
What output are you getting?
What characterset are you using?
Re: Problem with high ASCII characters in Oracle 11G [message #643442 is a reply to message #643441] Wed, 07 October 2015 09:40 Go to previous messageGo to next message
BlackSwan
Messages: 25858
Registered: January 2009
Location: SoCal
Senior Member
>Please help me out..

Problem exists with client, database, or OS having or using incompatible character set.
Re: Problem with high ASCII characters in Oracle 11G [message #643468 is a reply to message #643442] Thu, 08 October 2015 02:59 Go to previous messageGo to next message
Xandot
Messages: 235
Registered: January 2014
Location: India
Senior Member
Character set:
Parameter               Value
---------------------------------------    
NLS_CHARACTERSET	WE8ISO8859P9
NLS_NCHAR_CHARACTERSET	AL16UTF16



When I'm trying to execute below query then getting nothing.

select chr(144) from dual;

Re: Problem with high ASCII characters in Oracle 11G [message #643479 is a reply to message #643468] Thu, 08 October 2015 05:57 Go to previous messageGo to next message
Michel Cadot
Messages: 65389
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
BlackSwan wrote on Wed, 07 October 2015 16:40
Problem exists with client, database, or OS having or using incompatible character set.

Re: Problem with high ASCII characters in Oracle 11G [message #643500 is a reply to message #643479] Fri, 09 October 2015 02:53 Go to previous messageGo to next message
Xandot
Messages: 235
Registered: January 2014
Location: India
Senior Member
How can I check whether character set is incompatible or not ?

Which character set I can use for Oracle 11g DB ? So It can allow all the ASCII codes.
Re: Problem with high ASCII characters in Oracle 11G [message #643506 is a reply to message #643500] Fri, 09 October 2015 04:52 Go to previous message
Michel Cadot
Messages: 65389
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Did you check the client program, the client OS, your NLS settings?
You only post the database character set.

Previous Topic: VIEW TABLE OUT IN TERMINAL
Next Topic: Newbie with Questions? (domain vs logical vs structured) datatypes
Goto Forum:
  


Current Time: Sat Feb 24 07:06:55 CST 2018

Total time taken to generate the page: 0.03075 seconds