Re: Oracle 7445 Creating EM Repository

From: zigzagdna <>
Date: Thu, 4 Feb 2010 18:49:06 -0800 (PST)
Message-ID: <>

On Feb 3, 12:13 pm, joel garry <> wrote:
> On Feb 2, 8:26 pm, zigzagdna <> wrote:
> > I am using Oracle on HP UNIX 11.23 ia 64. When creating em
> > repository for database control , I get ORA-7445 error. When I created
> > my first  database instance I was lucky to get EM repository. IN my
> > other db instances I consistently get ORA-7445 error with core dump.
> > Does any one have work around for it? DB Control is so useful and alas
> > I cannot create it.  Setting up Grid Control is lot of work and who
> > knows I may run into same problem.
> Work with support, they seem to need some prodding to fix things in
> the hp space, especially for dbconsole.  In 10204 it is just lame, I'm
> going through that now with support, and seeing things like "Couldn't
> duplicate" on the most obvious screwups.  If what I'm seeing has any
> relation at all to 11g, check to see that the actually shuts
> and starts the proper java session when you give it commands that
> involve that.  Check to see that the logs don't mention anything about
> ports in use (um, assuming you are using different ports for each?).
> It's supposed to be fixed in 11g, but what I'm seeing is that emctl
> doesn't shut down the java session that actually controls the port, so
> it sortakinda works the second time, but really doesn't, so you get
> into strange mixed states, sometimes the only way to tell is to check
> the date of the java process.  This comes from the code in
> being for other platforms, so I can't help wondering from your post if
> the "fix" for 11g is just to make it die rather than being confused.
> I haven't got to look at that pl yet so I don't know how it
> distinguishes between the dbconsole process and the java process
> (which is a semantic screwup as far as I can tell in the 10g).  My
> support analyst clarified that:
> "3 processes are started with the DBConsole application.
> -- emagent.exe
> -- java.exe
> -- perl.exe"
> Funny, I don't see any exe's on hp-ux.  Anyways, I also noticed some
> crashes and restarts of java itself (evidence trail starts in
> emdb.nohup), so that spawned another SR, and I still don't know what
> is going on.  But I was able to determine, be sure all emagent, java
> and perl related processes are extinguished when you do any kind of
> reconfiguration.  That's easy for me, as only dbconsole is using java,
> but of course, YMMV.  The hard part for me is remembering that all the
> instructions on reconfiguring, patching and securing dbconsole from
> MOS and everywhere else don't account for this (unix platforms that
> aren't linux) problem, and so tend to make any problem worse.
> In your instances getting 7445, does anything else cause that, or is
> it only dbconsole?  There are MOS documents on what to do about 7445
> in general, I'm sure.
> jg
> --
> is bogus.
> "Give a cat a fish, he eats for a day.
> Try to teach a cat to fish, and he will claw your face until you give
> him a fish." - my kid told me that.

Thanks. I created a ticket with Oracle more than a week ago which was assigned to a developer. I have not gotten any response. I did look into the things you discuss in your e-mail but it appears what is happening is 11g is different. I also found a bug on same issue on metalink, so I think it is some Oracle internal issue. Received on Thu Feb 04 2010 - 20:49:06 CST

Original text of this message