Re: Missing archived logs in v$archived_log

From: zigzagdna <zigzagdna_at_yahoo.com>
Date: Mon, 21 Dec 2009 11:34:15 -0800 (PST)
Message-ID: <22ed8455-1692-4ad9-a09f-5761a5d60865_at_g7g2000yqa.googlegroups.com>



On Dec 20, 6:24 pm, zigzagdna <zigzag..._at_yahoo.com> wrote:
> On Dec 20, 10:31 am, bdbafh <bdb..._at_gmail.com> wrote:
>
>
>
>
>
> > On Dec 20, 12:39 am, zigzagdna <zigzag..._at_yahoo.com> wrote:
>
> > > I am using Oracle 11g 11.1.0.7 on HP UNIX 11.23. My database has been
> > > running in archived log mode.
> > > Yet when I go and look in v$archived_log, I see some archived logs
> > > missing,
> > > i.e, when I do select name from v$archived_log, I see:
> > > arch1_891_XXX.arc
> > > arch1_892_xxx.arc
> > > arch1_895_xxx.arc
>
> > > I see this happening every two three days,
> > > I do run
> > > alter system archive log current
> > > during my RMAN backups but that should not be the cause.
>
> > > I have seen  this behavior since I started using Oracle 11.1.0.7,
> > > never had this issue
> > > with older releases.
>
> > > I a not using any data guard. Any ideas will be greatly appreciated.
>
> > what do you see in the alert log regarding the log sequence# 893 being
> > archived?
>
> > -bdbafh- Hide quoted text -
>
> > - Show quoted text -
>
> I looked in alert.log. I do not see anything which indicates that this
> log was not archived. I do
> see
> ORA-19510: failed to set size of  blocks for file "" (block size=)
>
> Looking more in this error, it appears that archived logs are getting
> deleted while archive switch is being done.
> I have no clue who is deleting archived logs. My RMAN backup when they
> do archived log backup do
> not delete the archived log. Following configuration parameters for
> RMAN
>
> CONFIGURE RETENTION POLICY TO REDUNDANCY 30;
> CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default
>
> Should retain archived logs.
>
> Yet ARCHIVED LOGS are being depleted by some Oracle process. Clearly
> there is some bug in Oracle 11.1.0.7.- Hide quoted text -
>
> - Show quoted text -

Thanks.
My recovery window retention policy is set to 30, so 30 backups have to be reatined before deletion despite default deletion poilcy of NONE. You do not explain why v$archived_log has gaps for archive logs.

Same scripts have been working with Oracle9i and Oracle 10g. There is clearly undocumented (bug) behavior in Oracle 11g. Received on Mon Dec 21 2009 - 13:34:15 CST

Original text of this message