Re: installation error

From: Michael Austin <>
Date: Sat, 02 May 2009 20:01:37 -0500
Message-ID: <626Ll.29023$>

happytoday wrote:
> On Apr 20, 6:26 pm, Michael Austin <> wrote:
>> happytoday wrote:
>>> On Apr 20, 4:25 pm, Michael Austin <> wrote:
>>>> happytoday wrote:
>>>>> On Apr 19, 5:53 pm, Michael Austin <> wrote:
>>>>>> happytoday wrote:

>>>>>>> have downloaded all necessary packages needed for Oracle
>>>>>>> installation but with failure in installation as below :
>>>>>>> oracle _at_ inhome /opt/oracle/database>echo $DISPLAY
>>>>>>> oracle _at_ inhome /opt/oracle/database>./
>>>>>>> system SUNWbtool CCS tools bundled with SunOS
>>>>>>> system SUNWgcc gcc - The GNU C compiler
>>>>>>> system SUNWhea SunOS Header Files
>>>>>>> system SUNWi15cs X11 ISO8859-15 Codeset Support
>>>>>>> system SUNWi1cs X11 ISO8859-1 Codeset Support
>>>>>>> system SUNWi1of ISO-8859-1 (Latin-1) Optional Fonts
>>>>>>> system SUNWlibm Math & Microtasking Library Headers & Lint Files
>>>>>>> (Usr)
>>>>>>> system SUNWlibms Math & Microtasking Libraries (Usr)
>>>>>>> system SUNWtoo Programming Tools
>>>>>>> system SUNWuiu8 Iconv modules for UTF-8 Locale
>>>>>>> system SUNWxwdv X Windows System Window Drivers
>>>>>>> system SUNWxwfnt X Window System platform required fonts
>>>>>>> system SUNWxwplr X Window System platform software configuration
>>>>>>> system SUNWxwplt X Window System platform software
>>>>>>> ERROR: information for "SUNWwfrun" was not found
>>>>>>> ERROR: information for "SUNWsport" was not found
>>>>>>> oracle _at_ inhome /opt/oracle/database>. runInstaller
>>>>>>> Starting Oracle Universal Installer...
>>>>>>> Checking installer requirements...
>>>>>>> Checking operating system version: must be 5.10. Actual 5.10
>>>>>>> Passed
>>>>>>> Checking Temp space: must be greater than 250 MB. Actual 1982 MB
>>>>>>> Passed
>>>>>>> Checking swap space: must be greater than 500 MB. Actual 2348 MB
>>>>>>> Passed
>>>>>>> Checking monitor: must be configured to display at least 256 colors
>>>>>>> >>> Could not execute auto check for display colors using
>>>>>>> command /
>>>>>>> usr/openwin/bin/xdpyinfo. Check if the DISPLAY variable is set.
>>>>>>> Failed <<<<
>>>>>>> Some requirement checks failed. You must fulfill these requirements
>>>>>>> before
>>>>>>> continuing with the installation,at which time they will be rechecked.
>>>>>>> Continue? (y/n) [n] q
>>>>>>> Continue? (y/n) [n] n
>>>>>>> User Selected: No
>>>>>>> Exiting Oracle Universal Installer, log for this session can be found
>>>>>>> at /tmp/OraInstall2009-04-18_09-39-12PM/
>>>>>>> installActions2009-04-18_09-39-12PM.log
>>>>>> To be an effective DBA you must also be a pseudo-SysAdmin to be able to
>>>>>> troubleshoot simple stuff like this.  Read the install guide and other
>>>>>> resources on configuring X-Windows to function with your server/pc.
>>>>> How can I configure DISPLAY variable and X-windows ? Any tutorials ?
>>>> As root
>>>> echo $DISPLAY
>>>> As Oracle
>>>> export DISPLAY=<same as root display>
>>> They are the same as below :
>>> root _at_ inhome />echo $DISPLAY
>>> root _at_ inhome />su - oracle
>>> Sun Microsystems Inc.   SunOS 5.10      Generic January 2005
>>> You have new mail.
>>> oracle _at_ inhome /export/home/oracle>echo $DISPLAY
>>> is my IP address . Is there is any editing should be done
>>> to /etc/hosts or /etc/nsswitch.conf ?
>> what happens when you execute:
>> As user Oracle:
>> /usr/openwin/bin/xdpyinfo
> Back to that problem I can not login as oracle user  and the login
> screen reboot itself . I followed exactly what is writtn inside the
> documentations . Those are my outputs :
> oracle _at_ inhome /export/home/oracle>/usr/openwin/bin/xdpyinfo
> Xlib: connection to "" refused by server
> Xlib: Invalid MIT-MAGIC-COOKIE-1 key
> /usr/openwin/bin/xdpyinfo:  unable to open display "".

**SOMETHING IS BROKEN ON THE CLIENT** configure it correctly.

> oracle _at_ inhome /export/home/oracle>cat /etc/hosts
> #
> # Internet host table
> #
> #
> # Merged entries from ipnodes into hosts on <Mon Oct 20 13:15:17 EET
> 2008>
> # Backup files saved in /etc/inet/ directory: hosts.premerge,
> ipnodes.premerge
> #
>       localhost
> ::1     localhost
>     inhome  loghost
> oracle _at_ inhome /export/home/oracle>cat .bash_profile
> umask 022
> export MANPATH=/usr/local/man:$MANPATH
> export ORACLE_BASE=/opt/oracle
> export ORACLE_SID=ORA10GR2
> #PATH=/usr/SUNWspro/bin:/usr/bin:/bin:/usr/sbin:/usr/ccs/bin:/usr/
> local/bin:/usr/openwin/bin
> export PATH=/usr/openwin/bin:/opt/schily/bin:/usr/proc/bin:$PATH
> export MANPATH=$MANPATH:/opt/schily/man:/usr/local/share/man/man1
> export PS1="$LOGNAME _at_ `uname -n` \$PWD>"
> export DISPLAY=
> oracle _at_ inhome /export/home/oracle>

It is quite apparent that you are not yet ready to even pretend to be a DBA. You need to spend a LOT of time learning how the pieces parts play together. The fact you have been having this particular problem for a couple of weeks now indicates just that. You can't learn to use a carpenters saw until you first master the tape measure, square and pencil. You are still trying to figure out how the pencil works (Solaris) and still need to get the very basics of the tape measure (XWindows) and the square (Universal Installer). The Saw is Oracle.

We cannot fix this for you as we can not see how you have thrown this thing together. You and your SUN admin are the only ones that can fix this... If it is a Sun box at your house and you ARE the admin, see the above paragraph.

Use google on all of the error messages you are getting, eventually you will find a match to your problem and the learning experience will be well worth the effort.

Hopefully you are not relying on DHCP for any of these systems. DHCP is BAD for servers [caveat, some would disagree with this, but having been doing this for a while now, most of them weren't even in diapers when i started and having fixed way too many issues this way, this is my professional opinion (as well as hard-coding full-duplex for switches auto-negotiate usually doesn't] Hard-code the IP addresses and if necessary add them to your /etc/hosts file on all of your boxes.

Again, you have way too many pieces that appear to be misconfigured. Sometimes you need to start from the beginning and go through every single configuration item to make sure you did it correctly. Received on Sat May 02 2009 - 20:01:37 CDT

Original text of this message