Re: Oracle 10g 10.0.2 client, to connect oracle 8 server

From: Jesper Wolf Jespersen <Ingen_at_overhovedet>
Date: Mon, 28 Jul 2008 22:59:17 +0200
Message-ID: <488e3328$0$56788$>

> I am using Oracle 10 g 10.0.2 client software to connect 9i,10g and
> 8i
> it is working very good with the 9i and 10g..
> when i trying to connect 8i server ./. it giving error
> <b> "ORA-03134: Connections to this server version are no longer
> supported." </b>
> Can i install, 2 or more version of oracle clients in same system,
> becoz .. currently using client software is well configured for some
> SQL server BI agents, if i un-install current 10g client, it will
> infect my software .. process..

Yes you can, I currently have 3 versions Oracle 8.0.4, Oracle 9.2 and Oracle 10.2 on my work PC. No problem.
> if, it can be possible, what kind of things i take care, before
> installation ..

If you want 8.0 compatibility you have to install the clients in numeric order, first 8, then 8.1, then 9 then 10. The older versions dont support multiple oralce homes.

> What is the best oracle client software can suitable for most of the
> server's

I use what fits the server, there is nothing like the real thing. Older clients dont understand new database featiures and vice versa. Particularly when using clients like import and export there is no real substitute for the right version.

It works fine to export from a 9 database with a 9 cleint and then import the dump file using oracle 10 import in a 10 base.

Versions are a pest but you have to live with them.

Greetings from Denmark
Jesper Wolf Jespersen Received on Mon Jul 28 2008 - 15:59:17 CDT

Original text of this message