Re: ORA-8102, why?

From: shakespeare <whatsin_at_xs4all.nl>
Date: Wed, 16 Jan 2008 15:11:13 +0100
Message-ID: <478e107e$0$85780$e4fe514c@news.xs4all.nl>

"Cristian Cudizio" <cristian.cudizio_at_yahoo.it> schreef in bericht news:26ce818d-7d12-4eb7-b0c1-221cf4aae15d_at_x69g2000hsx.googlegroups.com...
> Hello,
> i've an Oracle database with RAC 2 node version 10.1.0.5 on Linux
> Suse SLES9 64 bit. Recently i've
> got an error ORA-8102 during the execution of a procedure that was
> deleting some records. So i have found that
> there are two records (the table has over 90 milions of records) for
> which there are no corresponding index entry on one of the indexes.
> I've read metalink notes 395006.1 and 1081343.6 and i can't understand
> how can it happen. The note 395006.1 say's about "lost write ore some
> similar OS issue" but how can be that there are no database block
> corruptions? The notes say also that dropping and recreating the index
> does not solve the issue. How can it be? is there anyone that can
> explain me that? Since the problem occurs only when i try to change
> the value of the indexed column for the two record or to delete the
> records i've choose to let things as are now, because exporting e re-
> importing the entire table woud be to expensive.
>
> Thanks,
>
> Cristian Cudizio
> http://oracledb.wordpress.com
> http://cristiancudizio.wordpress.com

Are you using a function based index on this table?

Shakespeare Received on Wed Jan 16 2008 - 08:11:13 CST

Original text of this message