Oracle FAQ Your Portal to the Oracle Knowledge Grid
HOME | ASK QUESTION | ADD INFO | SEARCH | E-MAIL US
 

Home -> Community -> Usenet -> c.d.o.server -> Re: NO LISTENER anger.

Re: NO LISTENER anger.

From: Carlos <miotromailcarlos_at_netscape.net>
Date: Mon, 05 Nov 2007 15:26:20 -0000
Message-ID: <1194276380.209424.99570@22g2000hsm.googlegroups.com>


On 5 nov, 15:52, Helma <helma.vi..._at_hotmail.com> wrote:
> Hello people,
>
> I'm having trouble in getting a EM console up and running on 10.2.0.1.
> I created the repository and then configured succesfully ( no errors
> in the emca logfile) with:
>
> emca -config dbcontrol db
>
> The error upon starting the webpage is:
>
> ORA-12541: TNS:no listener (DBD ERROR: OCIServerAttach)
>
> Needless to say is that the listener works ok and the database can be
> accessed without problems.
> On metalink i could only find :Note:363270.1 - which is about this
> error when you've changed portnumbers. Any pointer? Thanks in advance!

Hi Helma.

I faced something similar a while ago. Nobody knew why the em console wouldn't work. The person in charge of the DB (before me) had changed the listener port from 1512 to another (I cannot remember which).

The agent expected the listener listening on the old port and thus the ORA-12541. I reconfigured the agent emconfig (?) to let it know about the new listener port and everything worked fine ever after.

HTH. Cheers.

Carlos. Received on Mon Nov 05 2007 - 09:26:20 CST

Original text of this message

HOME | ASK QUESTION | ADD INFO | SEARCH | E-MAIL US