Re: dataguard connection question

From: Joan Hsieh <joan.hsieh_at_tufts.edu>
Date: Wed, 10 Jun 2009 15:46:53 -0400
Message-ID: <4A300DAD.1020704_at_tufts.edu>



I did, the error is the value is not sync with spfile and the broker. I don't know how to fix it. and I am not sure where is the LogXptMode (ARCH SYNC AFFIRM) came from.

Joan

QL> select * from v$logfile;

     GROUP# STATUS                TYPE
---------- --------------------- ---------------------
MEMBER

IS_RECOVE
          3                       ONLINE
/opt/XYTHT/redo1/XYTHT1/redo03.log
NO
          3                       ONLINE
/opt/XYTHT/redo2/XYTHT1/redo03.log
NO
          2                       ONLINE
/opt/XYTHT/redo1/XYTHT1/redo02.log
NO
          2                       ONLINE
/opt/XYTHT/redo2/XYTHT1/redo02.log
NO
          1                       ONLINE
/opt/XYTHT/redo1/XYTHT1/redo01.log
NO
          1                       ONLINE
/opt/XYTHT/redo2/XYTHT1/redo01.log
NO
          4                       STANDBY
/opt/XYTHT/redo1/XYTHT1/stby_redo4.log
NO
          5                       STANDBY
/opt/XYTHT/redo2/XYTHT1/stby_redo4.log
NO
          6                       STANDBY
/opt/XYTHT/redo1/XYTHT1/stby_redo5.log
NO
          7                       STANDBY
/opt/XYTHT/redo2/XYTHT1/stby_redo5.log
NO
          8                       STANDBY
/opt/XYTHT/redo1/XYTHT1/stby_redo6.log
NO
          9                       STANDBY
/opt/XYTHT/redo2/XYTHT1/stby_redo6.log
NO
         10                       STANDBY
/opt/XYTHT/redo1/XYTHT1/stby_redo7.log
NO
         11                       STANDBY
/opt/XYTHT/redo2/XYTHT1/stby_redo7.log
NO

14 rows selected.

Mathias Zarick wrote:

> Hi Joan,
>
> i guess you forgot to create standby redo logs on XYTHT1 ?
> They are needed when you switch to XYTHT2 to get properly running.
> A proper configuration is prerequisite for next switchover / switchback.
>
> HTH Mathias
>
> ________________________________
>
> Von: Joan Hsieh [mailto:joan.hsieh_at_tufts.edu]
> Gesendet: Mi 6/10/2009 20:57
> An: Mathias Zarick
> Cc: oracle_l
> Betreff: [SPAM] Re: dataguard connection question
>
>
>
> Thank you Mathias,
>
> Looks like I got it fixed. Our client can connect to the new service.
>
> However, I got a new problem. I tried to switchover again in order to
> test it. Swichover failed with ora-16725, 16809, 16629 errors ,
>
> I checked the log and did the following command in broker. I got the
> following results. I also did create pfile from spfile in order to check
> the value; I am not sure why the memory value show it is ARCH SYNC. It
> really puzzled me. The xytht1 (standby) the log_archive_dest_2 is null.
>
> please see the following value;
>
> *.log_archive_dest_2='service="XYTHT1"',' LGWR SYNC AFFIRM delay=0
> OPTIONAL compression=DISABLE max_failure=0 max_connec
> tions=1 reopen=300 db_unique_name="XYTHT1" net_timeout=30
> valid_for=(online_logfile,primary_role)'
> *.log_archive_dest_state_1='ENABLE'
>
>
> DGMGRL> show database 'XYTHT2' InconsistentLogXptProps
> INCONSISTENT LOG TRANSPORT PROPERTIES
> INSTANCE_NAME STANDBY_NAME PROPERTY_NAME MEMORY_VALUE BROKER_VALUE
> XYTHT2 XYTHT1 LogXptMode (ARCH SYNC AFFIRM) SYNC (= LGWR SYNC AFFIRM)
>
>
>
> Thanks,
>
> Joan
>
>
>
>
>
> My Oracle Support (the new MetaLink) Bookmarks Admin Profile
> Feedback Sign Out Help
>
> Copyright 2005, Oracle. All rights reserved. Legal Notices and Terms
> of Use | Privacy Statement
>
>
>
>
> Thanks,
>
> Joan
>
>
>
>
>
>

--
http://www.freelists.org/webpage/oracle-l
Received on Wed Jun 10 2009 - 14:46:53 CDT

Original text of this message