"Row Source Operation" missing from tkprof output

From: Vladimir Barac <vbarac_at_Alghanim.com>
Date: Wed, 31 Dec 2008 12:30:12 +0300
Message-ID: <C85D70C785B07043A485C8AE85E8F671043AAEE04B@ALGMB.Alghanim.com>

Hi, listers

I am facing a bit strange situation, so maybe somebody had experienced this before...

When 10046 tracing some procedure (executed manually at SQL*Plus prompt or as a part of some other procedure), TKPROF doesn't show "Row Source Operation" at all.

If I take out statements (all are updates) and execute them manually or as a part of unnamed PL/SQL block, TKPROF will show "Row Source Operation" and everything is fine.

What could be the reason for this?

All pointers to enlightenment are welcomed,

Vladimir Barac
Database administrator | Alghanim Industries P.O. Box 223, Safat 13003, Kuwait
Tel: +965 1881 111 / ext. 2960

This e-mail message and any attachments to it are for the sole use of the intended recipients and may contain confidential and privileged information. This e-mail message and any attachments are the property of Yusuf A. Alghanim & Sons w.l.l. or any of its subsidiaries or affiliates (“Alghanim Industries”). Any unauthorized review, use, disclosure, or distribution of this e-mail message or its attachments is prohibited. Any opinions expressed in this message are those of the author and do not necessarily reflect the opinion of Alghanim Industries. If you are not an intended recipient, please notify the sender by reply e-mail and destroy all copies of the original message and any attachments.


Received on Wed Dec 31 2008 - 03:30:12 CST

Original text of this message