Oracle FAQ Your Portal to the Oracle Knowledge Grid
HOME | ASK QUESTION | ADD INFO | SEARCH | E-MAIL US
 

Home -> Community -> Mailing Lists -> Oracle-L -> Re: Oracle streams - part 2

Re: Oracle streams - part 2

From: Finn Jorgensen <finn.oracledba_at_gmail.com>
Date: Wed, 24 Oct 2007 15:41:13 -0400
Message-ID: <74f79c6b0710241241g451d3af0ic1f9eae7ee1fc0cd@mail.gmail.com>


Do you have a database link pointing back from the destination database to the source database?

Could you paste the commands you used to set this up in the first place?

Finn

On 10/24/07, Fedock, John (KAM.RIC) <John.Fedock_at_us.kline.com> wrote:
>
> Source database is HP-UX, 10.1.0.5 and target database is HP-UX, 10.2.0.3
>
>
>
> I set this up manually (1 test table), however I do use the EM console to
> look for the errors and start/stop the processes.
>
>
>
> One thing I just thought of is that when I get the errors listed below, I
> delete the txn via the apply gui interface of EM and then reset the scn and
> then just enter more test data. Is this not a correct thing to do? Or
> maybe the question is when I get the ORA-26687 errors, how should I fix?
>
>
>
> Thanks all.
>
>
>
>
> ------------------------------
>
> *From:* Finn Jorgensen [mailto:finn.oracledba_at_gmail.com]
> *Sent:* Wednesday, October 24, 2007 2:51 PM
> *To:* Fedock, John (KAM.RIC)
> *Cc:* Asif Momen; oracle-l_at_freelists.org
> *Subject:* Re: Oracle streams - part 2
>
>
>
> Hi John.
>
>
>
> 1) Which version of Oracle are you using?
>
> 2) Did you happen to use OEM to set this up and/or did you start out with
> just a few tables or a single schema and then later added more
> tables/schemas to the same streams process?
>
>
>
> This second part is known to cause issues. I was recommended by Oracle to
> add another streams process for adding objects later, rather than just
> adding them to an existing streams process.
>
>
>
> Finn
>
>
>
> On 10/24/07, *Fedock, John (KAM.RIC)* <John.Fedock_at_us.kline.com> wrote:
>
> I finally got my Streams working (with a very small test) last night. The
> target database was shutdown and brought back up this morning. The APPLY
> process was aborted, so I restarted and now I am back to the ora-26687
> errors. I have reset the scn several times and I am still getting these
> errors.
>
>
>
> Needless to say, this whole streams process is very frustrating to me.
>
>
>
> Does shutting down the target database, without stopping streams cause the
> SCNs to not be in sync after it is brought back up?
>
> I know I am resetting the SCN, as I see the value change in DBA_APPLY_INSTANTIATED_OBJECTS
> .
>
>
>
> All the documents in MetaLink and Google say the same thing:
>
>
>
> "Set the SCN by calling DBMS_APPLY_ADM.SET_INSTANTIATION_ SCN" which I
> have done countless times.
>
>
>
> Can someone throw me a bone and steer me in the right direction.
>
>
>
> TIA.
>
>
>
> John Fedock
>
>
>
>
>
>
>
>
>

--
http://www.freelists.org/webpage/oracle-l
Received on Wed Oct 24 2007 - 14:41:13 CDT

Original text of this message

HOME | ASK QUESTION | ADD INFO | SEARCH | E-MAIL US