Oracle FAQ Your Portal to the Oracle Knowledge Grid

Home -> Community -> Mailing Lists -> Oracle-L -> AW: 10G and UFS - long write times

AW: 10G and UFS - long write times

From: <>
Date: Thu, 8 Jun 2006 10:19:27 +0200
Message-ID: <>


if you're really using this script you're issuing 50000 commits - no wonder it takes so long. Make the commit at least outside the loop!  


-----Ursprüngliche Nachricht-----

Von: [] Im Auftrag von Hallas, John, Tech Dev Gesendet: Donnerstag, 8. Juni 2006 10:16 An:
Betreff: 10G and UFS - long write times

We are seeing big problems when issuing disk writes using 10G (both 10.1 and 10.2). Reads are not an issue

Very difficult to track down the exact combination but so far it looks as if it is a combination of 10G and local disk mounted using UFS .

V440 Solaris servers could also come into the combination because that is what I have done a lot of the testing on as that is what is available. I have now tested on around 10-12 servers with consistent findings.  

The test is very simple and quick to do. Searching Metalink and WebIV does not give any clues. I am about to log a tar but I know I will require all sorts of Unix information which is quite long-winded for me to get so any help would be appreciated.  

The test  

CREATE TABLE test( a number, b CHAR(2000) )tablespace xxxx ;  

Set timing on  

BEGIN       FOR r IN 1..50000 LOOP

            INSERT INTO test (a,b) VALUES (r, 'test');

            COMMIT;       END LOOP; END   On SAN disk and 9i on local UFS mounted disk I am seeing response times from 0:15 to 0:30 seconds

On 10G on San I see the same

On 10G using local UFS disk the time various from 7:00 to 9:00 minutes and is very repeatable.  

I have tried around 10 servers now and the results are consistent.  

Whilst we have quite a few 10G installations, not many are on local disk and the majority are on Sun 440 (2.9 OS) so my results may indicate a UFS problem when it could be an OS one (or an Oracle one of course). OS writes to disk are stable at twice as fast on San as local disk and the fact that 90i does not show a problem seems to take away the OS part out of the equation. But nothing is certain yet.

PS the waits are all IO related - log buffer , log file sync etc  

Thanks for any help  


-- Received on Thu Jun 08 2006 - 03:19:27 CDT

Original text of this message