Home » SQL & PL/SQL » SQL & PL/SQL » Getting ORA-00604 followed by ORA-1003 (Oracle 10g, Windows XP)
Getting ORA-00604 followed by ORA-1003 [message #309124] Wed, 26 March 2008 08:43 Go to next message
Messages: 74
Registered: November 2007
Location: mumbai
Hi all,

I am facing one wiered issue as,

I have a Procedure which I tested in My dev environment, my Staging environment and works fine but I tried the same
in Production environment,its giving error

ORA -00604: Error Occurred at recursive SQL level 1.
ORA -1003 : No statement parsed

I am not able to understand this, all environments are just different Databases (all are Oracle 10g only).

Could you suggest what is possible reason for this,

My Code is simple Procedure which takes REF Cursor as input and returns Dataset using the same.

Please suggest.

Re: Getting ORA-00604 followed by ORA-1003 [message #309125 is a reply to message #309124] Wed, 26 March 2008 08:46 Go to previous messageGo to next message
Messages: 24963
Registered: January 2009
Location: SoCal
Senior Member
Why do you expect us to debug your code when you choose NOT post EXACTLY & completely what you are doing & how Oracle responds using CUT & PASTE?

I have ORA-01555 error tell me how to fix it.
Re: Getting ORA-00604 followed by ORA-1003 [message #309150 is a reply to message #309124] Wed, 26 March 2008 11:10 Go to previous message
Messages: 64
Registered: July 2005
Location: Here!
Check this link:

Just scroll waaaaay down. (The problem is in the SQL statement you are passing)

[Updated on: Wed, 26 March 2008 11:15]

Report message to a moderator

Previous Topic: Using CASE in WHERE Clause
Next Topic: Cost and Performance
Goto Forum:

Current Time: Tue Oct 25 14:30:49 CDT 2016

Total time taken to generate the page: 0.07836 seconds