Home » RDBMS Server » Server Administration » SGA MAX SIGE (Windows 2003 (32 bit))
SGA MAX SIGE [message #309103] Wed, 26 March 2008 07:34 Go to next message
emind
Messages: 49
Registered: April 2007
Location: Islamabad
Member
I want to change my SGA MAX SIZE from 1G to 2G on windows 2003 but when i change it it's show me ORA-27100 Shared memory realm already exits.i have total 4 GB RAM in system.
Please tell me what is the solution for this.
Re: SGA MAX SIGE [message #309104 is a reply to message #309103] Wed, 26 March 2008 07:35 Go to previous messageGo to next message
emind
Messages: 49
Registered: April 2007
Location: Islamabad
Member
Database version is 10g R2.
Re: SGA MAX SIGE [message #309109 is a reply to message #309103] Wed, 26 March 2008 07:53 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
Post the command
Re: SGA MAX SIGE [message #309111 is a reply to message #309109] Wed, 26 March 2008 07:57 Go to previous messageGo to next message
emind
Messages: 49
Registered: April 2007
Location: Islamabad
Member
ALter System set SGA_MAX_SIZE=2G scope=spfile;
Re: SGA MAX SIGE [message #309122 is a reply to message #309111] Wed, 26 March 2008 08:35 Go to previous messageGo to next message
Michel Cadot
Messages: 64110
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Copy and paste your session.
Don't forget to format it as requested in guidelines.

Regards
Michel
Re: SGA MAX SIGE [message #309342 is a reply to message #309103] Thu, 27 March 2008 03:02 Go to previous messageGo to next message
emind
Messages: 49
Registered: April 2007
Location: Islamabad
Member
SQL>startup
ORA-27100: shared memory realm already exists
Re: SGA MAX SIGE [message #309347 is a reply to message #309342] Thu, 27 March 2008 03:10 Go to previous messageGo to next message
Michel Cadot
Messages: 64110
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
So shutdown it first.

Regards
Michel
Re: SGA MAX SIGE [message #309360 is a reply to message #309103] Thu, 27 March 2008 03:42 Go to previous messageGo to next message
emind
Messages: 49
Registered: April 2007
Location: Islamabad
Member
I already shutdown database this message come when i try to start the database.if i start with pfile it's working fine because the impact of 2G parameter is only on SPfile.
is there any limitation in Oracle to change the SGA MAX size.
Re: SGA MAX SIGE [message #309369 is a reply to message #309360] Thu, 27 March 2008 04:22 Go to previous messageGo to next message
Michel Cadot
Messages: 64110
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Use ipcs to find shared memroy used by Oracle instance and remove it with ipcrm.

Regards
Michel
Re: SGA MAX SIGE [message #309377 is a reply to message #309103] Thu, 27 March 2008 04:49 Go to previous messageGo to next message
emind
Messages: 49
Registered: April 2007
Location: Islamabad
Member
IPCS is for unix it's windows 2003 and i restart the Machine but it's same error.
Re: SGA MAX SIGE [message #309389 is a reply to message #309377] Thu, 27 March 2008 05:24 Go to previous message
Michel Cadot
Messages: 64110
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Set Oracle services in manual mode before restarting and then restart server.
In Windows, you have to set some parameters.
Have a look at Metalink note Implementing Address Windowing Extensions (AWE) or VLM on Windows Platforms, n225349.1 and other associated ones.

Regards
Michel
Previous Topic: alter rollback segment
Next Topic: Status Pending
Goto Forum:
  


Current Time: Mon Dec 05 10:53:12 CST 2016

Total time taken to generate the page: 0.10410 seconds