Home » Developer & Programmer » Forms » Unable to Open report (9.0.4 Dev suit,win XP)
Unable to Open report [message #306023] Wed, 12 March 2008 10:25 Go to next message
hellozishan
Messages: 5
Registered: September 2007
Location: CY
Junior Member
Hi ,
I have used code but when I tried to run report by click button a message arise "FRM-41214 Unable to run report" . I create report object named "report6" and then set its properties

Filename=c:\cust_print.rdf
Destination Type=screen
Destination Formate=pdf
Report Server=reptest

and used following code in the when button pressed trigger

DECLARE
repid REPORT_OBJECT;
v_rep VARCHAR2(100);
rep_status varchar2(20);

BEGIN
repid := find_report_object('report6');
v_rep := RUN_REPORT_OBJECT(repid);
rep_status := report_object_status(v_rep);
if rep_status = 'FINISHED' then message('Report
Completed'); copy_report_object_output(v_rep,'c:\cust_print.rdf');
-- host('netscape d:/temp/local.pdf'); else
message('Error when running report.');
end if;
END;


When I click Button then unable to run report message arise and this report is running in report builder.
Where is the problem any idea?
I am using 9.0.4 dev suit.
Best Regards

Re: Unable to Open report [message #306026 is a reply to message #306023] Wed, 12 March 2008 10:38 Go to previous messageGo to next message
Kaeluan
Messages: 179
Registered: May 2005
Location: Montreal, Quebec
Senior Member
I don`t know if your form with your button is running locally or from an App Server, but it look like you are not able to see your report server.

Is your Report server on the same server as your application?


Re: Unable to Open report [message #306030 is a reply to message #306026] Wed, 12 March 2008 10:55 Go to previous messageGo to next message
hellozishan
Messages: 5
Registered: September 2007
Location: CY
Junior Member
Hi,

I am using 9.0.4, and if I use url my to browser then its working fine it means that my report server is working fine.
so where is the problem ? if my report is open in web browser??

Regards
Re: Unable to Open report [message #307446 is a reply to message #306030] Tue, 18 March 2008 22:47 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Search this forum for 'web.show_document'.

David
Previous Topic: Extracting data into Forms from electronics balance machine
Next Topic: how to pass record group to report
Goto Forum:
  


Current Time: Sun Dec 04 16:33:30 CST 2016

Total time taken to generate the page: 0.07741 seconds