Home » Developer & Programmer » Warehouse Builder » Problem running a XML-Load within OWB10.2.0.2 (OWB 10.2.0.2, Oracle 9.2.0.7)
Problem running a XML-Load within OWB10.2.0.2 [message #303186] Thu, 28 February 2008 04:42 Go to next message
Uwe
Messages: 260
Registered: February 2003
Location: Zürich, Switzerland
Senior Member
hello all,

we do have an error running a Package inside OWB which loads XML in a table.

BEGIN cds_pr_load_xml('/FJT/T/C02SWI.160','/opt/cds/T/xsl/cds_swift_message.xsl','cds_tmp_swift_message','message'); END;

*
ERROR at line 1:
ORA-20011:  Error occurred while loading source XML document into the target database object CDS_TMP_SWIFT_MESSAGE.
Base exception: 'oracle.jdbc.driver.OracleSQLException: ORA-01031: insufficient privileges
' encountered during processing ROW element 1.  All prior XML row changes were rolled back. in the XML document.
ORA-06512: at "OWB10G_RUNTIME.WB_XML_LOAD_F", line 12
ORA-06512: at "OWB10G_RUNTIME.WB_XML_LOAD", line 4
ORA-06512: at "CDS.CDS_PR_LOAD_XML", line 16
ORA-06512: at line 1


If I follow up the error messages it seems that the internal OWB-Package OWBXMLTK brought up the problem.
We tried to grant explicit the execute on the Package to the running User, but always the same problems.
The import-table is callable from sqlplus with the user.
Private synonyms are created to access the WB_XML_LOAD_F and WB_XML_LOAD.

any suggestions ?
thanks
uwe
Re: Problem running a XML-Load within OWB10.2.0.2 (with Workaround) [message #303217 is a reply to message #303186] Thu, 28 February 2008 07:35 Go to previous message
Uwe
Messages: 260
Registered: February 2003
Location: Zürich, Switzerland
Senior Member
We just found the root cause and activate a workaround. But I guess i will report it in Metalink.

On 10gR1 it works fine
On 10gR2 we do need
grant select, insert, update, delete on <temp-table>

The same if we do not set
truncateFirst="FALSE"
in CDS_PR_XML_LOAD Procedure.

Both things were not neccesary on 10gR1 and should be configured during the creation of the OWB repository.

OWB10gR2 seems to be a bit buggy in some embedded procedures Mad

regards
Uwe



Previous Topic: Snowflake schema
Next Topic: error loading flat file
Goto Forum:
  


Current Time: Sat Dec 10 20:28:39 CST 2016

Total time taken to generate the page: 0.08189 seconds