Home » Developer & Programmer » Forms » ORA-06508 in Form using library (DB 10g and forms 10g)
ORA-06508 in Form using library [message #302998] Wed, 27 February 2008 09:37 Go to next message
Kaeluan
Messages: 179
Registered: May 2005
Location: Montreal, Quebec
Senior Member
Hello, here is my problem.

I have 2 user/schema, USER_A and USER_B.
I installed the same database script that create the object in both schema.

I have 1 form that have 1 library attached. Both are compiled using USER_A.

If i am connecting on the Application server, or even testing locally, using USER_A everything work fine.
But if i am logging using USER_B i am getting error ORA-06508-Could not find program unit being called. I track the error and i can confirm that it raise when calling the function in the library. I know the problem is not the library path since it work with one user but not the other.

Also the application is using the PLX of the library and there is no PLL in the path.

Thank for helping

Re: ORA-06508 in Form using library [message #303818 is a reply to message #302998] Sun, 02 March 2008 23:30 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Quote:
ORA-06508: PL/SQL: could not find program unit being called
Cause: An attempt was made to call a stored program that could not be found. The program may have been dropped or incompatibly modified, or have compiled with errors.
Action: Check that all referenced programs, including their package bodies, exist and are compatible.

Does USER_A have any database procedures or packages?

David
Re: ORA-06508 in Form using library [message #304266 is a reply to message #302998] Tue, 04 March 2008 12:46 Go to previous messageGo to next message
michaeljshannon
Messages: 1
Registered: March 2008
Junior Member
Could be that the library function is calling a database procedure or package as David says.

You may also be right in saying that both users have privileges to the library.

This does not necessarily mean that both users have the same privilege to all contents within the library.

Double-check the grant privileges using SQL or TOAD.
Re: ORA-06508 in Form using library [message #304279 is a reply to message #302998] Tue, 04 March 2008 13:15 Go to previous message
Kaeluan
Messages: 179
Registered: May 2005
Location: Montreal, Quebec
Senior Member
Only to let you know that i solved my problem.

Our library was using an object type and it seem that forms seem to have some problem to handle that even if everything compile correctly.

To solve my problem, my library is now calling a controller package to convert my object type into record and send it back to forms. so now everything work correctly.

Thank for your help


Martin
Previous Topic: Restricting some users from connecting with database using tools other than forms Runtime, Repor
Next Topic: FRM-10142: The HTTP Listener is not .......
Goto Forum:
  


Current Time: Sat Dec 10 20:50:47 CST 2016

Total time taken to generate the page: 0.07531 seconds