Home » RDBMS Server » Enterprise Manager » emca failed on MGMT_VIEW user create with ORA-00988 error (10gr2 with sun 5.10)
emca failed on MGMT_VIEW user create with ORA-00988 error [message #302689] Tue, 26 February 2008 11:16 Go to next message
schihdba
Messages: 2
Registered: February 2008
Location: USA
Junior Member
When I create EM by using
emca -config dbcontrol db -repos create
I got following error

INFO: Creating the EM repository (this may take a while) ...
Feb 25, 2008 6:47:07 PM oracle.sysman.emcp.EMReposConfig createRepository
CONFIG: ORA-00988: missing or invalid password(s)
ORA-06512: at line 40

oracle.sysman.assistants.util.sqlEngine.SQLFatalErrorException: ORA-00988: missing or invalid password(s)
ORA-06512: at line 40


I knew I can't use password begin with number. so, I reset all of password to "manager" including sysman,dbsnmp,sys and system.

then, remove EM successfully by using
emca -deconfig dbcontrol db -repos drop

unfortunately, problem still exist after trying to create, again. Check on oracle forum, someone has the same problem but get no response. Hopefully, I can have luck here.
Re: emca failed on MGMT_VIEW user create with ORA-00988 error [message #303064 is a reply to message #302689] Wed, 27 February 2008 20:13 Go to previous messageGo to next message
rhziaDBA
Messages: 17
Registered: February 2008
Location: Madrid
Junior Member
the password of sysman must be change in several places not only in the bbdd

search a metalink note for procedure of sysman password change
Re: emca failed on MGMT_VIEW user create with ORA-00988 error [message #303221 is a reply to message #303064] Thu, 28 February 2008 07:43 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

http://dbataj.blogspot.com/2007/07/change-sysman-password.html

hope this help
Re: emca failed on MGMT_VIEW user create with ORA-00988 error [message #303246 is a reply to message #303221] Thu, 28 February 2008 09:14 Go to previous message
schihdba
Messages: 2
Registered: February 2008
Location: USA
Junior Member
Here is solution from oracle and I have tried successfully.
1.
emca -deconfig dbcontrol db -repos drop

2 cd $ORACLE_HOME/sysman/admin/emdrep/sql/core/latest/user_model
3. cp user_create_view_user.sql user_create_view_user.bak
4. vi user_create_view_user.sql
Change
DEFINE EM_REPOS_PWD = "&1"
by
DEFINE EM_REPOS_PWD = "test"

5.
emca -config dbcontrol db -repos create

input sysman password as "test"

Previous Topic: Server error ORA-1
Next Topic: OEM DBC problem
Goto Forum:
  


Current Time: Mon Dec 05 02:33:41 CST 2016

Total time taken to generate the page: 0.18714 seconds