Home » SQL & PL/SQL » Client Tools » How to disable shortcut or change key mapping?
How to disable shortcut or change key mapping? [message #300936] Mon, 18 February 2008 15:09 Go to next message
marko.sutic
Messages: 4
Registered: February 2008
Location: Zagreb, Croatia
Junior Member
Hi,

I have a problem with getting '|' sign in TOAD Editor.

It is default for Croatian keyboard layout that I get '|' sign when I press Alt_gr+W key combination.

But in Toad, when I press Alt_gr+W combination Watches dialog is opened.

How to disable this?

I want to get '|' sign in Toad Editor when I press Alt_gr+W.


Thanks for possible answer!
Re: How to disable shortcut or change key mapping? [message #300937 is a reply to message #300936] Mon, 18 February 2008 15:19 Go to previous messageGo to next message
Littlefoot
Messages: 18833
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Well, it isn't only TOAD; Forms Builder does that as well (just as an example).

A workaround is to press <Ctrl + R> ("Find and replace text") and enter the pipe character (or two of them, if you'd like to use it for concatenation) into the "Text to find" field. Select what you've entered and press <Ctrl + C> to copy it into the clipboard. Paste it using <Ctrl + V>.

A stupid way to do that, but ... I don't know any better at the moment.

./fa/3919/0/

[Updated on: Mon, 18 February 2008 15:20]

Report message to a moderator

Re: How to disable shortcut or change key mapping? [message #300959 is a reply to message #300936] Mon, 18 February 2008 18:16 Go to previous messageGo to next message
marko.sutic
Messages: 4
Registered: February 2008
Location: Zagreb, Croatia
Junior Member
Yes, I have my own stupid way also.

Open notepad, enter the pipe character and then copy/paste...

You're way is somewhat easier to work with and I'll use it, but I am little disappointed that I can't use Alt_gr+W for pipes in Toad editor.

Still hoping that this "problem" will be fixed soon :/


Anyway thanks for answer!
Re: How to disable shortcut or change key mapping? [message #300961 is a reply to message #300936] Mon, 18 February 2008 18:21 Go to previous messageGo to next message
marko.sutic
Messages: 4
Registered: February 2008
Location: Zagreb, Croatia
Junior Member
btw another workaround could be using or ¤¤ or similar characters instead of pipes and then when you finished coding just use replace all Smile

but still... stupid way also...
Re: How to disable shortcut or change key mapping? [message #301010 is a reply to message #300961] Tue, 19 February 2008 00:18 Go to previous messageGo to next message
Littlefoot
Messages: 18833
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Or, we could use <Alt + 124> (press and hold 'Alt' and type '124').

There are options, but none of them is the right one; all these workarounds are simply painful.
Re: How to disable shortcut or change key mapping? [message #301018 is a reply to message #301010] Tue, 19 February 2008 00:27 Go to previous messageGo to next message
Frank
Messages: 7877
Registered: March 2000
Senior Member
Doesn't TOAD know macros with key-binding?
Then you could bind the alt-124 to (eg) ctrl-AltGr-W
Re: How to disable shortcut or change key mapping? [message #301073 is a reply to message #301018] Tue, 19 February 2008 02:30 Go to previous messageGo to next message
marko.sutic
Messages: 4
Registered: February 2008
Location: Zagreb, Croatia
Junior Member
Yes, it knows macros but as Littlefoot says - it's still another workaround.

thanks again
Re: How to disable shortcut or change key mapping? [message #573257 is a reply to message #301073] Tue, 25 December 2012 19:43 Go to previous messageGo to next message
janezkossi
Messages: 1
Registered: December 2012
Junior Member
AltGr is just a shortcut for Ctrl+Alt.
AltGr+W is therefore identical to Ctrl+Alt+W, which is a shortcut for Editor/Watches.
What you need to do is to remove or change this shortcut to something else, for example to Ctrl+Alt+V.
It's quite simple:
- Toad Options --> Toolbars/Menus --> Shortcuts
- click on Shortcut column to order the shortcuts
- locate Ctrl+Alt+W and select it
- enter the new key combination (just press the key combination you want)
or
- press Delete to remove the shortcut
Re: How to disable shortcut or change key mapping? [message #573266 is a reply to message #573257] Wed, 26 December 2012 02:51 Go to previous messageGo to next message
Littlefoot
Messages: 18833
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Whoa, that looks promising! I don't have TOAD here (and won't be able to test it until next week), but I'll certainly have a look. Thank you!
Re: How to disable shortcut or change key mapping? [message #573544 is a reply to message #573266] Mon, 31 December 2012 02:02 Go to previous message
Littlefoot
Messages: 18833
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
./fa/2115/0/

Marvelous! Can't be better! Thank you once again!
Previous Topic: substr invalid number of parameters
Next Topic: Cannot connect to DB remotely using sqlplus
Goto Forum:
  


Current Time: Sun Apr 20 20:08:41 CDT 2014

Total time taken to generate the page: 0.10930 seconds