Home » Developer & Programmer » Warehouse Builder » Problem starting OWB after OS Switch (Oracle 9.2.0.6, OWB 10gR2, Solaris 8 => 10)
Problem starting OWB after OS Switch [message #300836] Mon, 18 February 2008 04:10 Go to next message
Uwe
Messages: 260
Registered: February 2003
Location: Zürich, Switzerland
Senior Member
Hi all

we are facing a problem in starting OWB10gR2 on a Solaris10 Box on Orcle 9.2.0.6.
This was running under Solaris8, but after restoring/recovering the DB to a new server with the new OS Solaris 10 the service of OWB is not startable anymore.
The message is
Not available
Diagnostics:
service startup failure reason ORA-29532: Java call terminated by uncaught Java
exception: java.io.IOException


The Java-Log has nothing special in it:
Oracle9i Enterprise Edition Release 9.2.0.7.0 - 64bit Production
With the Partitioning option
JServer Release 9.2.0.7.0 - Production
ORACLE_HOME = /unshared/ei_olap/oracle/product/rdbms/9.2.0_01
System name:    SunOS
Node name:      usv0549
Release:        5.10
Version:        Generic_118833-36
Machine:        sun4u
Instance name: ADSQSU01
Redo thread mounted by this instance: 1
Oracle process number: 13
Unix process pid: 22027, image: oracle@usv0549 (J000)

*** SESSION ID:(13.103) 2008-02-18 11:02:40.463
java.io.IOException
  at java.io.UnixFileSystem.createFileExclusively(UnixFileSystem.java)
  at java.io.File.createNewFile(File.java)
  at oracle.wh.runtime.server.KeyManagement.getRtrProperties(KeyManagement.java:867)
  at oracle.wh.runtime.server.KeyManagement.getKey(KeyManagement.java:630)
  at oracle.wh.runtime.server.KeyManagement.decryptValue(KeyManagement.java:673)
  at oracle.wh.runtime.server.KeyManagement.getPlatformConfig(KeyManagement.java:217)
  at oracle.wh.runtime.server.KeyManagement.get_platform_config(KeyManagement.java:59)


there are some uncompileable functions for the runtime user, but I could not fix the problems reported
I have uploaded the file with the compile actions and error messages
any help is welcome
cheers
uwe


  • Attachment: errors.txt
    (Size: 3.21KB, Downloaded 884 times)
Re: Problem starting OWB after OS Switch [message #300868 is a reply to message #300836] Mon, 18 February 2008 06:58 Go to previous messageGo to next message
Uwe
Messages: 260
Registered: February 2003
Location: Zürich, Switzerland
Senior Member
We just fixed the problems.
The case was that we restored the DB completely from another host and the ORACLE_BASE Directory was changed.
This needs to be changed manually within the DB in
UPDATE OWBRT_SYS.OWBRTPS 
   SET   value='<PATH_TO_OWBHOME>'        
   WHERE key ='<OWB_VERSION>;

UPDATE OWB10G_RUNTIME.WB_RT_SERVICE_NODES 
   SET    host = '<hostname>'
        , port = <Portnumber>
        , service_name = '<SERVICENAME>
        , server_side_home = '<PATH_TO_OWBHOME>
   WHERE  node_id = 1;

UPDATE OWB10G_RUNTIME.WB_RT_STORE_PARAMETERS 
   SET    parameter_value = '<DB_NAME>' 
   WHERE  parameter_name  = 'Service';

UPDATE OWB10G_RUNTIME.WB_RT_STORE_PARAMETERS 
   SET    parameter_value = '<HOSTNAME>' 
   WHERE  parameter_name  = 'Host';

UPDATE OWB10G_RUNTIME.WB_RT_STORE_PARAMETERS 
   SET    parameter_value = '<PORT>' 
   WHERE  parameter_name  = 'Port';

The Initial Parameter needs to be checked / changed :
ALTER SYSTEM SET SERVICE_NAMES='ADSPBP01','ADSPBP01.WORLD';
ALTER SYSTEM REGISTER;

At least it maybe neccesary to reset the properties file :
as runtime user:
reset_repository.sql 

from OWBHOME/owb/rtc/sql

This fixed all errors at our side
Uwe
Re: Problem starting OWB after OS Switch [message #357163 is a reply to message #300868] Tue, 04 November 2008 03:18 Go to previous messageGo to next message
rattyce
Messages: 2
Registered: November 2008
Junior Member
We encounter same problem whilst trying to start OWB service.
We tried as suggested above but the problem remains.
We got
Enter value for repos_password: rep_owner
old 2: wb_rti_util.reset('&REPOS_PASSWORD.');
new 2: wb_rti_util.reset('rep_owner');
begin
*
ERROR at line 1:
ORA-29532: Java call terminated by uncaught Java exception: java.io.IOException
ORA-06512: at "REP_OWNER.WB_RTI_UTIL", line 29
ORA-06512: at "REP_OWNER.WB_RTI_UTIL", line 93
ORA-06512: at line 2

Please help!

THanks in advance
Arunrat S.
Re: Problem starting OWB after OS Switch [message #411508 is a reply to message #300836] Sat, 04 July 2009 08:06 Go to previous message
acastro
Messages: 1
Registered: July 2009
Location: México
Junior Member

The post place by Uwe, worked for me, we just reorganize an oracle 10g DB in other disk volume and it was giving the same error. We just changed the OWB path home fields, and run the reset_repository script, control service started without any problem.

update wb_rt_service_nodes
set server_side_home = '/OWB';

/*to run this you have to be connected as SYS*/
UPDATE OWBRT_SYS.OWBRTPS
SET VALUE='/OWB'
WHERE KEY='10.2.0.4.36[1]';

Previous Topic: bulk delete
Next Topic: Need help on importing data from datasources with different characterset
Goto Forum:
  


Current Time: Fri Dec 09 04:15:31 CST 2016

Total time taken to generate the page: 0.08182 seconds