Home » RDBMS Server » Server Utilities » Error while using IMP  () 1 Vote
Error while using IMP [message #299670] Tue, 12 February 2008 23:07 Go to next message
it_me24
Messages: 167
Registered: March 2006
Location: delhi
Senior Member
HI All,

I am facing an issu while using import.

please help in solving the problem.

Import statement:

imp asdwlbdb/asdwlbdb file=/home/june/intapdata2/unidb_nov07/as/dump/asdwlbdb_ac_081207_21:05:00.dmp
log=/home/june/impas.log
tables=AC_PREPAID_UPLOAD:SEP07
fromuser=asdwlbdb
touser=asdwlbdb
constraints=y
grants=y
ignor=y
buffer=104857600


while running the Imp command i get the following error.

Export file created by EXPORT:V10.01.00 via direct path
import done in US7ASCII character set and AL16UTF16 NCHAR character set
import server uses WE8ISO8859P1 character set (possible charset conversion)
IMP-00031: Must specify FULL=Y or provide FROMUSER/TOUSER or TABLES arguments
IMP-00000: Import terminated unsuccessfully

Please advice in solving the isssue.

thanks in advance.
Re: Error while using IMP [message #299675 is a reply to message #299670] Tue, 12 February 2008 23:23 Go to previous messageGo to next message
trantuananh24hg
Messages: 668
Registered: January 2007
Location: Ha Noi, Viet Nam
Senior Member
it_me24 wrote on Wed, 13 February 2008 12:07
HI All,

I am facing an issu while using import.

please help in solving the problem.

Import statement:

imp asdwlbdb/asdwlbdb file=/home/june/intapdata2/unidb_nov07/as/dump/asdwlbdb_ac_081207_21:05:00.dmp
log=/home/june/impas.log
tables=AC_PREPAID_UPLOAD:SEP07
fromuser=asdwlbdb
touser=asdwlbdb
constraints=y
grants=y
ignor=y
buffer=104857600


Are you sure about the user who exported this file is ASDWLBDB?

Quote:

while running the Imp command i get the following error.
.............................................................
Export file created by EXPORT:V10.01.00 via direct path
import done in US7ASCII character set and AL16UTF16 NCHAR character set
import server uses WE8ISO8859P1 character set (possible charset conversion)
IMP-00031: Must specify FULL=Y or provide FROMUSER/TOUSER or TABLES arguments
IMP-00000: Import terminated unsuccessfully

Please advice in solving the isssue.


Use Full=Y to import instead of FromUser/ToUser. By default, these parameter Tables, Indexes, Constraints are set to Y (Yes), so that, you do not need to give it in your command.

[Updated on: Tue, 12 February 2008 23:24]

Report message to a moderator

Re: Error while using IMP [message #299678 is a reply to message #299670] Tue, 12 February 2008 23:28 Go to previous messageGo to next message
it_me24
Messages: 167
Registered: March 2006
Location: delhi
Senior Member
Hi,
I modified the command below.

imp asdwlbdb/asdwlbdb file=/home/june/intapdata2/unidb_nov07/as/dump/asdwlbdb_ac_081207_21:05:00.dmp
log=/home/june/impas.log
tables=AC_PREPAID_UPLOAD:SEP07
FULL=Y
constraints=y
grants=y
ignor=y
buffer=104857600


but still the error comes as below.

Export file created by EXPORT:V10.01.00 via direct path
import done in US7ASCII character set and AL16UTF16 NCHAR character set
import server uses WE8ISO8859P1 character set (possible charset conversion)
IMP-00031: Must specify FULL=Y or provide FROMUSER/TOUSER or TABLES arguments
IMP-00000: Import terminated unsuccessfully

please suggest, it is very urgent.

thanks again
Re: Error while using IMP [message #299680 is a reply to message #299670] Tue, 12 February 2008 23:30 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
never mind

[Updated on: Tue, 12 February 2008 23:30] by Moderator

Report message to a moderator

Re: Error while using IMP [message #299686 is a reply to message #299670] Tue, 12 February 2008 23:36 Go to previous messageGo to next message
it_me24
Messages: 167
Registered: March 2006
Location: delhi
Senior Member
any body please
Re: Error while using IMP [message #299702 is a reply to message #299686] Wed, 13 February 2008 00:04 Go to previous messageGo to next message
Enrique2k
Messages: 2
Registered: February 2008
Location: Kuwait
Junior Member
Hello

remove full=y and try again

Regards,
Re: Error while using IMP [message #299713 is a reply to message #299670] Wed, 13 February 2008 00:23 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
Quote:
ignor=y

I hope the missing "e" is not causing any error.

Do it this way:
imp asdwlbdb/asdwlbdb file=/home/june/intapdata2/unidb_nov07/as
/dump/asdwlbdb_ac_081207_21:05:00.dmp
log=/home/june/impas.log
tables=AC_PREPAID_UPLOAD:SEP07
constraints=y
grants=y
ignore=y
buffer=104857600
It will prompt for the username,give asdwlbdb

[Updated on: Wed, 13 February 2008 00:24]

Report message to a moderator

Re: Error while using IMP [message #299740 is a reply to message #299670] Wed, 13 February 2008 01:20 Go to previous message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Given that this question is also posted at http://www.dba-village.com/village/dvp_forum.OpenThread?ThreadIdA=31958&SkipA=0 but with small differences in the command, I think this is a fake question and is likely noone can find the good answer as we don't have the correct question.

Regards
Michel
Previous Topic: Are inserts NLS sensitive?
Next Topic: convert .txt to .dbf and vice versa
Goto Forum:
  


Current Time: Sat Dec 10 14:53:53 CST 2016

Total time taken to generate the page: 0.27863 seconds