Home » RDBMS Server » Server Administration » BLOB Issue (Oracle 10g R1)
BLOB Issue [message #297620] Fri, 01 February 2008 14:41
ggeorge
Messages: 1
Registered: July 2007
Location: Baton Rouge
Junior Member
Hi All,
I have this task of UPDATING a BLOB column in some tables and replacing it with EMPTY_BLOB since the column is defined as NOT NULL. I replace the contents of the BLOB column and run a STORED_PROC that opens the updated BLOB and TRIMS it. My problem is after this excercise I find that the SYS_IL000xxxx$$ segment gets bigger in size and flows into another EXTENT. The rest of the values under the DBA_SEGMENTS for the table remains the same. Can anyone explain this phenomenon ? Please check the values in the BOLD

BEFORE UPDATE

SEGMENT_NAME PARTITION_NAME SEGMENT_TYPE TABLESPACE_NAME HEADER_FILE HEADER_BLOCK BYTES BLOCKS EXTENTS INITIAL_EXTENT
APP_ATTACHMENTS TABLE USERS 63 450091 65536 8 1 65536
SYS_IL0000131960C00005$$ LOBINDEX USERS 63 450067 65536 8 1 65536
SYS_LOB0000131960C00005$$ LOBSEGMENT USERS 63 450059 45088768 5504 58 65536


AFTER UPDATE

SEGMENT_NAME PARTITION_NAME SEGMENT_TYPE TABLESPACE_NAME HEADER_FILE HEADER_BLOCK BYTES BLOCKS EXTENTS INITIAL_EXTENT
APP_ATTACHMENTS TABLE USERS 63 450091 65536 8 1 65536
SYS_IL0000131960C00005$$ LOBINDEX USERS 63 450067 131072 16 2 65536
SYS_LOB0000131960C00005$$ LOBSEGMENT USERS 63 450059 45088768 5504 58 65536

JeeKay
Previous Topic: How to properly size the SGA?
Next Topic: OS authentication
Goto Forum:
  


Current Time: Sat Dec 10 12:52:50 CST 2016

Total time taken to generate the page: 0.07625 seconds