Home » Developer & Programmer » Reports & Discoverer » Problem with DESNAME (Report 10g)
icon5.gif  Problem with DESNAME [message #296287] Fri, 25 January 2008 10:13 Go to next message
kwaam_rak
Messages: 14
Registered: July 2007
Junior Member
I am running a report on the AS with a DESNAME specifying a directory in the server. This is set in the AfterParam trigger. The code is something like this:

:DESNAME := 'G:\report\output\myreport.pdf'

The directory G:\report\output\ exists in the AS.

The report executes but it does not write the pdf file in the specified directory. Instead, it writes the pdf file in the cache directory.

Any ideas on why it did not follow the value in DESNAME?
Re: Problem with DESNAME [message #296453 is a reply to message #296287] Sun, 27 January 2008 10:01 Go to previous messageGo to next message
vamsi kasina
Messages: 2107
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Does this post help you?

By
Vamsi
Re: Problem with DESNAME [message #297599 is a reply to message #296453] Fri, 01 February 2008 12:10 Go to previous messageGo to next message
kwaam_rak
Messages: 14
Registered: July 2007
Junior Member
I read the threads starting from the link you gave and eventually came to this stmt made in the Oracle forum:

Quote:
DESNAME can not have more than 20 characters...


Isn't 20 characters so limiting? I can't believe Oracle would implement such a restriction. DESNAME's length is 1024 in the Report property. Why would it be restricted to a mere 20? Anyway, even if I am astonished to learn about this restriction, I tried it and still get the same problem.

Anymore ideas/solutions?
icon5.gif  Re: Problem with DESNAME [message #298035 is a reply to message #297599] Mon, 04 February 2008 12:51 Go to previous messageGo to next message
kwaam_rak
Messages: 14
Registered: July 2007
Junior Member
Anyone?
Re: Problem with DESNAME [message #298782 is a reply to message #298035] Thu, 07 February 2008 11:56 Go to previous message
kwaam_rak
Messages: 14
Registered: July 2007
Junior Member
I was able to get into Metalink since my last post and got a solution from there.

For those who have no access to Metalink, and are having the same problems, do a research on how to distribute/burst your report. Forget about dynamically building the desname because it will never work in 10g. The approach is to distribute/burst the report.
Previous Topic: Server name in report
Next Topic: Re: How to pass values from Forms to Reports
Goto Forum:
  


Current Time: Mon Dec 05 02:28:21 CST 2016

Total time taken to generate the page: 0.08665 seconds