Home » Developer & Programmer » Forms » AVOIDING OF MESSAGES (developer 6i second release)
AVOIDING OF MESSAGES [message #295702] Wed, 23 January 2008 02:29 Go to next message
ashraf_al_ani
Messages: 92
Registered: October 2007
Location: Iraq
Member
Dear All

When i save a record a message appears that ask me to save and number of records to be saved
so how can I avoid such messages

Best regards
Re: AVOIDING OF MESSAGES [message #295710 is a reply to message #295702] Wed, 23 January 2008 02:46 Go to previous messageGo to next message
azamkhan
Messages: 548
Registered: August 2005
Senior Member
If you are talking about the following Message:

"FRM-40400:Transaction complete: 2 records applied and saved"

Then my dear friend you can capture this message on ON_MESSAGE trigger and suppress it. Through ON_MESSAGE trigger you can capture different other message as well.
Re: AVOIDING OF MESSAGES [message #295759 is a reply to message #295702] Wed, 23 January 2008 05:52 Go to previous messageGo to next message
ashraf_al_ani
Messages: 92
Registered: October 2007
Location: Iraq
Member
yes thanks I mean this message
but pls can u explain more
best regards
Re: AVOIDING OF MESSAGES [message #295772 is a reply to message #295759] Wed, 23 January 2008 06:48 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
One of a simple solutions is to change message level. To do that, create two form-level triggers; here are their names and codes. Basically, you'll suppress all messages whose level is lower than 15. After committing changes, restore the original message level.
-- PRE-COMMIT

:global.current_msg_level := :system.message_level;

:SYSTEM.MESSAGE_LEVEL := 15;
-- POST-DATABASE-COMMIT 

:SYSTEM.MESSAGE_LEVEL := :global.current_msg_level;

Re: AVOIDING OF MESSAGES [message #297868 is a reply to message #295702] Mon, 04 February 2008 01:19 Go to previous messageGo to next message
ashraf_al_ani
Messages: 92
Registered: October 2007
Location: Iraq
Member
Dear

I have these 2 messages appear when i save the record
its number is frm-40105
its number is frm-40737
so pls tell me how can i avoid the appearing of these messages
in details

best regards

Re: AVOIDING OF MESSAGES [message #297913 is a reply to message #297868] Mon, 04 February 2008 04:00 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
FRM-40105: unable to resolve reference to item <item_name>
        -> don't go to non-existent (or disabled) item

FRM-40737: Illegal restricted procedure <procedure_name> in <trigger_name>
        -> don't use restricted built-ins in triggers that fire in response to navigation
Re: AVOIDING OF MESSAGES [message #382689 is a reply to message #297913] Fri, 23 January 2009 10:30 Go to previous messageGo to next message
mkhalil
Messages: 108
Registered: July 2006
Location: NWFP Peshawar Pakistan
Senior Member
So noice of you Littlefoot. I am also facing such problem i,e. FRM-40400 message and now solved. Once again thanks.
Re: AVOIDING OF MESSAGES [message #384315 is a reply to message #295702] Tue, 03 February 2009 04:27 Go to previous message
athar.fitfd@hotmail.com
Messages: 193
Registered: October 2007
Location: pakistan
Senior Member
you people can write your own custom message.

or use null to avoid any message.
Previous Topic: delete button
Next Topic: LOV validation
Goto Forum:
  


Current Time: Fri Dec 02 18:48:28 CST 2016

Total time taken to generate the page: 0.22835 seconds