Home » SQL & PL/SQL » Client Tools » Unable to connect (TOAD 9, 10G, Win xp, 10g forms, 10g reports)
Unable to connect [message #294831] Sat, 19 January 2008 21:13 Go to next message
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member

I have this problem which confuses me.

I am able to connect to the 10g database with TOAD but when I try to connect to the database through command prompt or from forms or reports it says 'unable to connect'.

I assume this has something to do with sqlnet.ora and tnsnames.ora file but not very sure

Thanks in advance

- Das
Re: Unable to connect [message #294843 is a reply to message #294831] Sun, 20 January 2008 00:54 Go to previous messageGo to next message
Michel Cadot
Messages: 63929
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
It is likely the reason but without more information than "unable to connect" it is impossible to say.

Re: Unable to connect [message #294870 is a reply to message #294831] Sun, 20 January 2008 05:43 Go to previous message
Messages: 20847
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
It seems that you have (and use) more than one copy of TNSNAMES.ORA and SQLNET.ORA files.

A problem you have can (usually) be resolved by copying these files from \network\admin directory of a product that enables you to connect to the database (it is usually directory into which you have installed Oracle database) into \network\admin directory of the Developer Suite (which contains Forms and Reports Builders).

However, as such an approach requires you to maintain multiple copies of these files, I'd suggest you to use only one copy. You might point to this directory by setting the TNS_ADMIN environment variable.
Previous Topic: sql-query
Next Topic: Capture OCI sql HELP
Goto Forum:

Current Time: Wed Oct 26 12:41:17 CDT 2016

Total time taken to generate the page: 0.13093 seconds