Home » Developer & Programmer » Forms » Go_item is not working (Form 6i ,widows xp)
icon11.gif  Go_item is not working [message #291681] Sat, 05 January 2008 23:10 Go to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member


Hi Gurus,

Here I have form. when i click the button
i wrote program like under 'when_button_pressed'

:Global.Mode := 'ADD';

:DCTYPE := 'DCS';
:DcName := 'DC SUBCONTRACT';

:AnnexMain.Periodid:=:Global.Periodid;
:AnnexMain.Unitid  :=:Global.Unitid;



Declare

Slno  Number(4);


Begin
     
Message(' UID '||:Global.Unitid||' PID '||:Global.Periodid);
     Select Doc_type,Doc_Date,Serial_Number INto :Dtype,:DocDt,Slno From Lastdocs 
                  Where Substr(doc_Type,2,3)='116'
                    and Periodid = :AnnexMain.Periodid
                    and UNitid   = :ANnexMain.Unitid;


     :AnnexMain.Documentno     :=  :Dtype||Lpad(To_Char(Slno+1),4,'0');
     :AnnexMain.Documentdate   :=  :Docdt;
  -- Set_item_property('Annexmain.DOcumentno', 'ENABLE',Property_False);
  Go_Item('AnnexMain.DocumentDate');

Exception
When NO_data_found Then
Message( 'Last document Pickup Failure ! Please check Unitid & Period Id ');
Raise form_trigger_failure;
End;


But When it meets 'Go_item('AnnexMain.DocumentDate');
The Form closed automatically.

pls need best help

wbr
kanish
Re: Go_item is not working [message #291829 is a reply to message #291681] Mon, 07 January 2008 00:21 Go to previous message
mintomohan
Messages: 104
Registered: November 2006
Location: India
Senior Member
hi,

could you please try giving a go_block before go_item:

Go_Block('AnnexMain');
Go_Item('AnnexMain.DocumentDate');



Minto
Previous Topic: adjustable canvas
Next Topic: Which Trigger and What Level?
Goto Forum:
  


Current Time: Wed Dec 07 18:26:58 CST 2016

Total time taken to generate the page: 0.13811 seconds