Home » Developer & Programmer » Forms » Running Forms (10g)
Running Forms (10g) [message #290492] Sat, 29 December 2007 02:36 Go to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Guys,

I created a form and tried to run it but got an error that HTTP was not configured and I need to add a listener at port 8889.

I did so, now when I run the form it opens in a browser but the form does not appear...I can just see 'ORACLE FORMS' written on the top left corner of the page and the bottom left I see message 'Waiting for (computer name)' does anyone know why this is happening ...how to run the form so that it behaves just like normal front end developed in any programming language like .net, asp..

Shouldn't I be seeing the form like a front page in a browser...

Please assist me.

- Das
Re: Running Forms (10g) [message #290536 is a reply to message #290492] Sat, 29 December 2007 09:48 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Before running a form developed by Builder 9i or 10g, start the OC4J instance. Also, check that pop-up blocker of your internet browser is disabled. If you use MS Internet Explorer, check that Tools - Internet options - Advanced - Security - Allow active content to run in files on My Computer is checked.
Re: Running Forms (10g) [message #290542 is a reply to message #290536] Sat, 29 December 2007 10:57 Go to previous messageGo to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Thanks a lot Littlefoot..

Can you show me how to start OC4J ....

I read about invoking oc4j.jar to start OC4J but that file is not available on oracle_home..

Thanks in advance

- Das
Re: Running Forms (10g) [message #290547 is a reply to message #290542] Sat, 29 December 2007 14:54 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
On MS Windows operating system, you'd go to Start - All Programs - Oracle Developer Suite - Forms Developer - Start OC4J instance. I wouldn't know how to do that on other operating systems.
Re: Running Forms (10g) [message #290551 is a reply to message #290547] Sat, 29 December 2007 20:27 Go to previous messageGo to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Thanks a lot.

I tried to start the instance but I came across this error
' Error starting HTTP-Server: Address already in user: JVM_Bind'

Can you tell me what should be done in this case?

- Das
Re: Running Forms (10g) [message #290552 is a reply to message #290547] Sat, 29 December 2007 20:46 Go to previous message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Hey..I got it man..


thanks a lot..actually earlier when I did not know about OC4J instance..it had asked me about configuring listener at port 8889 and I did that manually...I disabled it and restarted ..tried again and it worked fine...I am able to see the form in the browser now..

Thanks again...
Previous Topic: How to Create Both Vertical & Horizontal Scrollbars for a data block
Next Topic: Pass a message From PLSQL Procedure To Forms (D2k)
Goto Forum:
  


Current Time: Sun Dec 11 08:11:39 CST 2016

Total time taken to generate the page: 0.09943 seconds