Home » RDBMS Server » Server Administration » Incomplete but installation had reported succesful (Oracle 10g fedora 5 + 7)
Incomplete but installation had reported succesful [message #290246] Fri, 28 December 2007 03:22 Go to next message
aidi-h
Messages: 44
Registered: November 2005
Member

Can someone please advise, In the past I have been running a test database on a Virtual session of Fedora 4 and doing various work on that which works fine. Unfortunetely, I have been advised that I will not be able to use this VM, so I have now downloaded a virtual appliance of Fedora 5 and 7 (as I could not find a standard installation of virtual appliance of Fed 4). I then installed Oracle 10G with the "-ignoreSysPrereqs" option set, i.e. ./runInstaller -responseFile /u01/app/oracle1.rsp -silent -ignoreSysPrereqs.
This carries on and reports that the Oracle application has been succesfully installed but on investigation, I find that some of the program are just empty files, e.g. sqlplus, sqlldr and some of $ORACLE_HOME/lib files are missing.
Is this down to the version of Fedora and that fact I used -ignoreSysPrereqs to bypass the preinstall checks.
Any information would be useful.
Re: Incomplete but installation had reported succesful [message #290371 is a reply to message #290246] Fri, 28 December 2007 10:21 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
AFAIK this parameter "-ignoreSysPrereqs" bypass only the initial checks for ram,swap and display.

Do you have there executable in $ORACLE_HOME/bin ?
Do you able to connect to sqlplus?
Re: Incomplete but installation had reported succesful [message #290379 is a reply to message #290246] Fri, 28 December 2007 11:08 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
>This carries on and reports that the Oracle application has been succesfully installed
Forgive me, but I doubt the above statement is 100% correct.
With the -silent option provided, AFAIK no feedback is provided

Post proof using CUT & PASTE that "Oracle application has been succesfully installed"
Re: Incomplete but installation had reported succesful [message #290500 is a reply to message #290246] Sat, 29 December 2007 02:59 Go to previous messageGo to next message
aidi-h
Messages: 44
Registered: November 2005
Member
Here is a sample of files in $ORACLE_HOME/bin for DreamzZ
"-bash-3.1$ pwd
/u01/app/product/10.2.1/db_1/bin
-bash-3.1$ ls -ls sql*
4 -rwxr-xr-x 1 oracle oinstall 0 Jun 30 2005 sqlldr
4 -rwxr-xr-x 1 oracle oinstall 0 Jun 22 2005 sqlldrO
4 -rwxr-xr-x 1 oracle oinstall 0 Jun 30 2005 sqlplus
4 -rwxr-xr-x 1 oracle oinstall 0 Jun 22 2005 sqlplusO
-bash-3.1$
"
Most of the other executable files are exactly the same in that they are empty.


In regard to anacedent, here are some comments output from one of the log files,

"Installation in progress (Thu Dec 20 01:10:52 EST 2007)
............................................................... 11% Done.
............................................................... 23% Done.
............................................................... 35% Done.
............................................................... 47% Done.
........................................... 55% Done.
Install successful

Linking in progress (Thu Dec 20 01:13:52 EST 2007)"


Hope this helps
Re: Incomplete but installation had reported succesful [message #290535 is a reply to message #290246] Sat, 29 December 2007 09:37 Go to previous message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
>Linking in progress (Thu Dec 20 01:13:52 EST 2007)"
Was the linking process 100% successful too?
Previous Topic: Error while trying to create a database manually
Next Topic: Oracle Users
Goto Forum:
  


Current Time: Sun Dec 04 08:43:37 CST 2016

Total time taken to generate the page: 0.10972 seconds