Home » Server Options » RAC & Failsafe » unable to start both intances on 11g RAC (Oracle Linux R5, Oracle 11gR1)
unable to start both intances on 11g RAC [message #290160] Thu, 27 December 2007 18:08 Go to next message
yomick
Messages: 2
Registered: December 2007
Junior Member
Following Jeffrey Hunter guide. Installing 2 node RAC on Oracle EL5 w/ 11g

All cluvfy operations successful up to this point of running dbca from node1 (lin1).

Errorwhen starting ASM instance on node lin2: PRKS-1009: Failed to start ASM instance "+ASM2 on node "lin2"...[CRS-0233: Resource or relatives are currently involved with another operation.]

[root@lin1 bin]# ./crs_stat -t
Name Type Target State Host
------------------------------------------------------------
ora....SM1.asm application ONLINE ONLINE lin1
ora....N1.lsnr application ONLINE ONLINE lin1
ora.lin1.gsd application ONLINE ONLINE lin1
ora.lin1.ons application ONLINE ONLINE lin1
ora.lin1.vip application ONLINE ONLINE lin1
ora....SM2.asm application ONLINE OFFLINE
ora....N2.lsnr application ONLINE ONLINE lin2
ora.lin2.gsd application ONLINE ONLINE lin2
ora.lin2.ons application ONLINE ONLINE lin2
ora.lin2.vip application ONLINE ONLINE lin2

[root@lin1 bin]# ./crs_start ora.lin2.ASM2.asm
Attempting to start `ora.lin2.ASM2.asm` on member `lin2`

[root@lin1 bin]# pwd
/u01/app/crs/bin

[root@lin1 bin]# ./crs_start ora.lin2.ASM2.asm
Attempting to start `ora.lin2.ASM2.asm` on member `lin2`
Start of `ora.lin2.ASM2.asm` on member `lin2` failed.
lin1 : CRS-1019: Resource ora.lin2.ASM2.asm (application) cannot run on lin1
CRS-0215: Could not start resource 'ora.lin2.ASM2.asm'.

[root@lin1 bin]# ./crs_stop ora.lin1.ASM1.asm
Attempting to stop `ora.lin1.ASM1.asm` on member `lin1`
Stop of `ora.lin1.ASM1.asm` on member `lin1` succeeded.

[root@lin1 bin]# ./crs_start ora.lin2.ASM2.asm
Attempting to start `ora.lin2.ASM2.asm` on member `lin2`
Start of `ora.lin2.ASM2.asm` on member `lin2` succeeded.

[root@lin1 bin]# ./crs_stat -t
Name Type Target State Host
------------------------------------------------------------
ora....SM1.asm application OFFLINE OFFLINE
ora....N1.lsnr application ONLINE ONLINE lin1
ora.lin1.gsd application ONLINE ONLINE lin1
ora.lin1.ons application ONLINE ONLINE lin1
ora.lin1.vip application ONLINE ONLINE lin1
ora....SM2.asm application ONLINE ONLINE lin2
ora....N2.lsnr application ONLINE ONLINE lin2
ora.lin2.gsd application ONLINE ONLINE lin2
ora.lin2.ons application ONLINE ONLINE lin2
ora.lin2.vip application ONLINE ONLINE lin2

...and so forth. I can't get both ASM instances to run concurrently. The dbca complains about whichever one is OFFLINE. When I try to start the OFFLINE instance I get something like:

[root@lin1 bin]# ./crs_start ora.lin2.ASM2.asm
Attempting to start `ora.lin2.ASM2.asm` on member `lin2`
Start of `ora.lin2.ASM2.asm` on member `lin2` failed.
lin1 : CRS-1019: Resource ora.lin2.ASM2.asm (application) cannot run on lin1
CRS-0215: Could not start resource 'ora.lin2.ASM2.asm'.

Am I missing something fundamental w/ the RAC install? Why is the on-line instance off-lined when the other off-line instance is started? The whole purpose is to cluster the instances???

[oracle@lin1 bin]$ crs_stat -t
Name Type Target State Host
------------------------------------------------------------
ora....SM1.asm application OFFLINE OFFLINE
ora....N1.lsnr application ONLINE ONLINE lin1
ora.lin1.gsd application ONLINE ONLINE lin1
ora.lin1.ons application ONLINE ONLINE lin1
ora.lin1.vip application ONLINE ONLINE lin1
ora....SM2.asm application ONLINE ONLINE lin2
ora....N2.lsnr application ONLINE ONLINE lin2
ora.lin2.gsd application ONLINE ONLINE lin2
ora.lin2.ons application ONLINE ONLINE lin2
ora.lin2.vip application ONLINE ONLINE lin2
[oracle@lin1 bin]$ crs_start ora.lin1.ASM1.asm
Attempting to start `ora.lin1.ASM1.asm` on member `lin1`
Start of `ora.lin1.ASM1.asm` on member `lin1` succeeded.

[oracle@lin1 bin]$ crs_stat -t
Name Type Target State Host
------------------------------------------------------------
ora....SM1.asm application ONLINE ONLINE lin1
ora....N1.lsnr application ONLINE ONLINE lin1
ora.lin1.gsd application ONLINE ONLINE lin1
ora.lin1.ons application ONLINE ONLINE lin1
ora.lin1.vip application ONLINE ONLINE lin1
ora....SM2.asm application ONLINE OFFLINE
ora....N2.lsnr application ONLINE ONLINE lin2
ora.lin2.gsd application ONLINE ONLINE lin2
ora.lin2.ons application ONLINE ONLINE lin2
ora.lin2.vip application ONLINE ONLINE lin2
[oracle@lin1 bin]$

Any assistance very much appreciated. - thx, yomick
Re: unable to start both intances on 11g RAC [message #290162 is a reply to message #290160] Thu, 27 December 2007 19:02 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Did you set the ASM Instance parameter correctly ?Ie for cluster database?
Re: unable to start both intances on 11g RAC [message #290372 is a reply to message #290160] Fri, 28 December 2007 10:25 Go to previous messageGo to next message
yomick
Messages: 2
Registered: December 2007
Junior Member
DreamzZ,

Thanks for the response. Here is what happens when I try your suggestion.
-----------------------------
[oracle@lin1 bin]$ sqlplus /nolog

SQL*Plus: Release 11.1.0.6.0 - Production on Fri Dec 28 07:01:05 2007 Copyright (c) 1982, 2007, Oracle. All rights reserved.

SQL> connect sys as sysdba
Enter password:
Connected to an idle instance.
SQL> startup mount
ORA-01078: failure in processing system parameters
LRM-00109: could not open parameter file '/u01/app/oracle/product/11.1.0/db_1/dbs/initorcl1.ora'
------------------------------
Couple of questions here:
1) If there is a running instance, then why would there be a problem with the parameter file? It was req'd to start the instance in the first place, correct?

2) How to change the "*.clustered_database" startup parameter you mention if I can't connect to issue "alter system set *.clustered_database=true"?
Re: unable to start both intances on 11g RAC [message #290373 is a reply to message #290372] Fri, 28 December 2007 10:32 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Using ASM before starting database make sure you ASM instance is UP.
Also check and post last 50 lines from Alert log file.

Quote:

1) If there is a running instance, then why would there be a problem with the parameter file? It was req'd to start the instance in the first place, correct?


Bit more specific for this question.

Quote:

2) How to change the "*.clustered_database" startup parameter you mention if I can't connect to issue "alter system set *.clustered_database=true"?


You have to manually edit you pfile and bounce the database.
Re: unable to start both intances on 11g RAC [message #337416 is a reply to message #290373] Wed, 30 July 2008 17:54 Go to previous message
sunil_v_mishra
Messages: 506
Registered: March 2005
Senior Member
I hope you are properly setting the ASM sid before starting the each ASM instance.

Try to start asm with srvctl command.

kindly check the diskgroup of ASM are they mounted properly?

[Updated on: Wed, 30 July 2008 17:54]

Report message to a moderator

Previous Topic: ORA-12505: TNS : Listener does not currently know of SID given in connect descripter
Next Topic: RAC services
Goto Forum:
  


Current Time: Wed Jul 30 05:46:19 CDT 2014

Total time taken to generate the page: 0.15690 seconds