Home » RDBMS Server » Server Administration » archive log
archive log [message #288601] Tue, 18 December 2007 02:59 Go to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
am configuring dataguard in ibm power pc.
when i try to change to archive mode,in primary site
i changed some parameter in spfile by using alter system set command as recommended.
i set the
log_archive_dest_1='location="/database/archivelog/tims"'
log_archive_format='ARC%S_%T_%R'
log_archive_start=TRUE

then i shutdown my primary database and startup as mount exclusive.

then i made alter system archivelog;

when i checked with archive log list;
everything is fine.
but when i checked in the archive log location no archive logs were found.

then i give alter system archive log current;
then it is showing the archive logs.
but it was not automatically generating the archive logs.

please tell me how to make the archive logs generating automatically?

thanks in advance.
Re: archive log [message #288605 is a reply to message #288601] Tue, 18 December 2007 03:06 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
When does archive log get generated?
When does ARC process archives the redo log files?
What happens when you issue alter system Archive log current command?

[Updated on: Tue, 18 December 2007 03:07]

Report message to a moderator

Re: archive log [message #288606 is a reply to message #288601] Tue, 18 December 2007 03:07 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You have to wait a little bit to get an archive log.

Regards
Michel
Re: archive log [message #288608 is a reply to message #288601] Tue, 18 December 2007 03:13 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Did you do any change in database before issuing alter system archive log current? And the parameter log_archive_start has no affect on 10g.
Re: archive log [message #288610 is a reply to message #288605] Tue, 18 December 2007 03:14 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
when i give alter system archive log current then only am getting the archive files in the archive log location.

without giving that command archive log files are not generating.
normally when we start and stop the database archive log files will generate but for me it was not generating?
Re: archive log [message #288611 is a reply to message #288601] Tue, 18 December 2007 03:17 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

You need not to worry about it. It is going in it's way.
Re: archive log [message #288613 is a reply to message #288601] Tue, 18 December 2007 03:19 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
i had made one of the instance down from my rac before i change the spfile parameters.
Re: archive log [message #288621 is a reply to message #288613] Tue, 18 December 2007 03:41 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You don't say you are in RAC.
You don't say exactly what you did.
You hide information and expect accurate help.

You're On Your Own (YOYO)!

Regards
Michel
Re: archive log [message #288673 is a reply to message #288601] Tue, 18 December 2007 05:01 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
my primary site is rac and my dr site is in single instance?
Re: archive log [message #288674 is a reply to message #288601] Tue, 18 December 2007 05:04 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
whenever am giving alter system archive log current
Its generating archive logs,without giving the above command its not generating archive logs.
Re: archive log [message #288682 is a reply to message #288674] Tue, 18 December 2007 05:21 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
But is there any activity?

Regards
Michel
Re: archive log [message #288685 is a reply to message #288601] Tue, 18 December 2007 05:37 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
i had started and stoped the database
Re: archive log [message #288687 is a reply to message #288685] Tue, 18 December 2007 05:46 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
This is a big activity, indeed.

Do something with your database.

Regards
Michel
Re: archive log [message #288691 is a reply to message #288601] Tue, 18 December 2007 06:09 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
i had created one table by name test,and i shutdown the database and started again but it was not showing any archive logs.
Re: archive log [message #288694 is a reply to message #288691] Tue, 18 December 2007 06:13 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Created one table is a very little activity.
Start filling it with one million rows and updating them and deleting them... or more depending on your log files.

Regards
Michel
Re: archive log [message #288698 is a reply to message #288601] Tue, 18 December 2007 06:33 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
i tried by adding 5 more tables and deleted some tables,
but still finding the same issue.
Re: archive log [message #288699 is a reply to message #288698] Tue, 18 December 2007 06:38 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Did you check archive log sequence number is changed ?
"archive log list"
after alter system switch logfile;

Re: archive log [message #288701 is a reply to message #288601] Tue, 18 December 2007 06:43 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
ya its same.
i had not used alter system switch logfile.
i had used alter system archive log current.
but after using the above commmand am getting the log files.
Re: archive log [message #288702 is a reply to message #288701] Tue, 18 December 2007 06:49 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Are you sure you are watching on the rac instance that you are executing?

Regards
Michel
Re: archive log [message #288706 is a reply to message #288601] Tue, 18 December 2007 06:59 Go to previous messageGo to next message
ara.oracle
Messages: 142
Registered: August 2007
Senior Member
great reply from you.
Re: archive log [message #288861 is a reply to message #288601] Tue, 18 December 2007 23:52 Go to previous message
varu123
Messages: 754
Registered: October 2007
Senior Member
Decrease the size of your redologfile and then try
Previous Topic: first ever clone
Next Topic: remote objects
Goto Forum:
  


Current Time: Sat Dec 03 09:48:35 CST 2016

Total time taken to generate the page: 0.06463 seconds