Home » SQL & PL/SQL » Client Tools » Use of toad formatted code in Unix (Oracle 10g on Unix)
Use of toad formatted code in Unix [message #288567] Tue, 18 December 2007 00:47 Go to next message
newtooracle123
Messages: 24
Registered: May 2007
Junior Member
Hi all,

I have a problem.
I use Toad formatter to format my code.
But if I use the same code to run on Oracle which is hosted on unix the tab charecter changes to some "^?"

Is there a way in which tabs can be changed to spaces?
Re: Use of toad formatted code in Unix [message #288775 is a reply to message #288567] Tue, 18 December 2007 11:23 Go to previous messageGo to next message
S.Rajaram
Messages: 1027
Registered: October 2006
Location: United Kingdom
Senior Member
It is ^I (Control+I) character . open the code in vi editor and do the following.

vi <file_name>
go to command mode (by entering : (colon))
then type s/<control+v>then type I/<blank space>/g then hit enter
the bits which i have mentioned within <..> are type by that particular key sequence.

HTH

Regards

Raj
Re: Use of toad formatted code in Unix [message #288798 is a reply to message #288567] Tue, 18 December 2007 14:09 Go to previous message
Littlefoot
Messages: 20900
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
You didn't mention your TOAD version, so this suggestion (based on TOAD 8.6.1) might (or might not) be helpful: select 'View' menu and 'Formatting Options'. Open 'General Layout' and click 'Tabs'. Change 'Output Tabs' to 'Insert spaces' (instead of 'Insert tabs').
Previous Topic: column name getting truncated upon displaying the result
Next Topic: Toad Current Schema Drop down toolbar
Goto Forum:
  


Current Time: Wed Dec 07 22:45:20 CST 2016

Total time taken to generate the page: 0.08822 seconds