Home » RDBMS Server » Performance Tuning » How to disable archivelog generation for a patricular session ? (oracle 9.2.0.2.0, sunsolaris 5.9)
How to disable archivelog generation for a patricular session ? [message #287201] Tue, 11 December 2007 06:54 Go to next message
kesavansundaram
Messages: 181
Registered: October 2007
Location: MUMBAI
Senior Member

Dear all,
Kindly confirm whether we can disable the archivelog generation for a patricular session in oracle 9i ? ( ver: 9.2.0.2.0 ).

thank you
kesavan
Re: How to disable archivelog generation for a patricular session ? [message #287202 is a reply to message #287201] Tue, 11 December 2007 06:56 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Archive log generated through REDOLOG.
and redolog generate according operation which you perform against database.
so please give us more details what is your actually requirements.
Re: How to disable archivelog generation for a patricular session ? [message #287204 is a reply to message #287202] Tue, 11 December 2007 07:01 Go to previous messageGo to next message
kesavansundaram
Messages: 181
Registered: October 2007
Location: MUMBAI
Senior Member

in my database, my redolog file size is around 100mb.
at o/s level, when we check the disk partition size, we have 30gb only for the patricular partition.

One user performing many Delete operations which are written in a PROCEDURE...which is generating much archivelog files.... further we don't have that much space to hold this many files.

what to be done further ?
can we set the database NOARCHIVELOG mode ?
or is there any way to disable the archivelog generations for that patricular user ?

thank you for your prompt reply.
kesavan.
Re: How to disable archivelog generation for a patricular session ? [message #287207 is a reply to message #287204] Tue, 11 December 2007 07:04 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
At any case, you cannot avoid redo generation. You may minimize it.
>>can we set the database NOARCHIVELOG mode ?
If you are willing to face the consequences.
>>or is there any way to disable the archivelog generations for that patricular user ?
No.
Re: How to disable archivelog generation for a patricular session ? [message #287208 is a reply to message #287207] Tue, 11 December 2007 07:06 Go to previous messageGo to next message
kesavansundaram
Messages: 181
Registered: October 2007
Location: MUMBAI
Senior Member

thank you for your prompt reply in this regard

kesavan.
Re: How to disable archivelog generation for a patricular session ? [message #287209 is a reply to message #287204] Tue, 11 December 2007 07:07 Go to previous message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

1. You can't disable archivelog for one particular session.
2. You can disable archivelog mode but i am not suggested if it is production database.
3. You can perform your operation after that you must take database backup and delete all archivelog files from backup.

(before delete all archivelog must sure you will take archivelog backup on tape drive)


Previous Topic: Poorly performing SQL query
Next Topic: IO Performance Problems
Goto Forum:
  


Current Time: Sat Dec 03 14:05:45 CST 2016

Total time taken to generate the page: 0.17253 seconds