Home » RDBMS Server » Server Utilities » Message 2100 not found;
Message 2100 not found; [message #287156] Tue, 11 December 2007 04:06 Go to next message
mitrashatru
Messages: 7
Registered: November 2007
Junior Member
Hi,
I am using sqlldr to load data into oracle DB using a data file. the sqlldr runs fine from the commandline. but, on running the same througha perl program, i get foll error: -

Message 2100 not found; No message file for product=RDBMS, facility=UL

As i can see that the oracle home and path is properly set. And also one another perl script runs without any problem. However, FYI, in the same script there is one more query with another database. can this be the cause?

Please help.
Re: Message 2100 not found; [message #287177 is a reply to message #287156] Tue, 11 December 2007 05:53 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
It has to do with your path.
Post your env settings.
Re: Message 2100 not found; [message #287195 is a reply to message #287177] Tue, 11 December 2007 06:38 Go to previous messageGo to next message
mitrashatru
Messages: 7
Registered: November 2007
Junior Member
Here you go: ->

ORACLE_HOME=>/qsatools/apps/oracle/9.2.0.client
MOSEKLM_LICENSE_FILE=>[email]23456@qsanyp1.gsr.etsd.ml.com[/email]:23456qsanyp6.gsr.etsd.ml.com:[email]23456@qsanyr1.gsr.etsd.ml.com[/email]
PS1=>${USER}@${HOST} $PWD $
QSA_DEV_HOME=>/home/qsa/dev
QSA_PROD_UDS=>/home/qsa/prod/uds
GCC_HOME=>/qsatools/gnu/gcc
LESSOPEN=>|/usr/bin/lesspipe.sh %s
QSA_PROD_HOME=>/home/qsa/prod
PWD=>/home/etd/skumar12
R_HOME=>/qsatools/thirdparty/R
LANG=>en_US.UTF-8
TCL_LIBRARY=>/qsatools/tools/tcl
USER=>etd
GDB_HOME=>/qsatools/gnu/gdb
G_BROKEN_FILENAMES=>1
LOGNAME=>etd
PRINTER=>qsa1hp8000
SHLVL=>1
INPUTRC=>/etc/inputrc
K3HOME=>/qsatools/thirdparty/k
PATH=> /qsatools/bin:/qsatools/tools/j2sdk1.4.2_07/bin:/qsatools/apps/eclipse:/qsatools/thirdparty/R/bin:/qsatools/gnu/gdb/bin:/qsatools/gnu /bin:/qsatools/gnu/gcc/bin:/qsatools/tools/WindowMaker/bin:/qsatools/tools/maven/bin:/gfs/prod/qsa/mosek/3.2.8/tools/platform/linux32 x86/bin:/home/qsa/prod/uds/bin:/home/etd/bin:/usr/kerberos/bin:/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/opt/local/bin:/apps/loca l/bin:/usr/X11R6/bin:/opt/VRTS/bin:/qsatools/gnu/gcc-3.4.3/bin:/qsatools/apps/oracle/9.2.0.5.client/bin
SUDO_USER=>skumar12
HASH(0x777800)=>
SYBASE=>/qsatools/apps/sybase_oc
HISTSIZE=>1000
TERM=>xterm
SUDO_COMMAND=>/usr/bin/ss -u etd
WINDOWMAKER_HOME=>/qsatools/tools/WindowMaker
LM_LICENSE_FILE=>[email]12222@qsanyr13.gsr.etsd.ml.com[/email]:[email]12222@qsanyr12.gsr.etsd.ml.com[/email]
SUDO_UID=>635753
HOME=>/home/etd
JAVA_HOME=>/qsatools/tools/j2sdk1.4.2_07
SYBASE_OCS=>OCS-12_5
GNU_HOME=>/qsatools/gnu
SUDO_GID=>20
LD_LIBRARY_PATH=> /qsatools/lib:/qsatools/tools/j2sdk1.4.2_07/lib:/qsatools/thirdparty/R/lib:/qsatools/gnu/gdb/lib:/qsatools/lib:/qsatools/gnu/lib:/qsa tools/gnu/gcc/lib:/qsatools/tools/WindowMaker/lib:/qsatools/tools/maven/lib:/qsatools/thirdparty/nag/cllux07ddl:/gfs/prod/qsa/mosek/3 .2.8/tools/platform/linux32x86/bin:/qsatools/apps/oracle/9.2.0.5.client/lib:
MAVEN_HOME=>/qsatools/tools/maven
MAIL=>/var/spool/mail/etd
ECLIPSE_HOME=>/qsatools/apps/eclipse
HOSTNAME=>mhs-apps5009-d
OLDPWD=>/home/etd
CVSROOT=>:pserver:[email]qsa@eq-nfs-d2-n1.dev.etsd.ml.com[/email]:/projects/CVSREPO/qsa
_=>./loadPmeBarraData.pl
SCRIPT_LOGIN_SHELL=>1
TMOUT=>0
DEJAGNULIBS=>/qsatools/gnu/dejagnu/share/dejagnu
LS_COLORS=> no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;3 2:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31: *.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=0 0;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
NAG_HOME=>/qsatools/thirdparty/nag
SHELL=>/bin/bash

-------------------------------------------------------
Any clue?

[Updated on: Tue, 11 December 2007 06:41] by Moderator

Report message to a moderator

Re: Message 2100 not found; [message #287198 is a reply to message #287195] Tue, 11 December 2007 06:46 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
As per your posting

ORACLE_HOME=>/qsatools/apps/oracle/9.2.0.client


But, in your PATH you are using
/qsatools/apps/oracle/9.2.0.5.client/bin
Re: Message 2100 not found; [message #287210 is a reply to message #287198] Tue, 11 December 2007 07:22 Go to previous message
mitrashatru
Messages: 7
Registered: November 2007
Junior Member
Very correct observation.
Thanks Mahesh. It works now Smile .

Thanks again.
Previous Topic: HOW CAN I RECOVER DATA IN ORACLE DATABASE 8.1.5 WHEN EXP COMMAND NOT WORKING
Next Topic: Import error
Goto Forum:
  


Current Time: Sat Dec 10 20:37:50 CST 2016

Total time taken to generate the page: 0.10159 seconds