Home » SQL & PL/SQL » Client Tools » Inserts Chinese Characters using INSERT INTO doesn't work (SQL Navigator 5.5)
Inserts Chinese Characters using INSERT INTO doesn't work [message #286784] Mon, 10 December 2007 02:12 Go to next message
pe00320
Messages: 1
Registered: December 2007
Location: Mexico
Junior Member
Hi,

I'm trying to insert this line into Oracle Database 10g (unicode) using SQL NAvigator and what it inserts are characters that are not chinese, like this: ¼: ¤¾Ųlineƥ, why?

INSERT INTO system_message (message_code, message_type, message_text, corrective_actions, short_message)
VALUES ('VB02-001','I','简体中文: 工作站号不与line相匹配
',简体中文: 请联系系统帮助部门','简体中文: 工作站号码与装配线不匹配')
;
But If I copy the chinese text and paste it directly in the record, I can see the chinese characters in database, because it is unicode. So, seems like the DML doesn't support chinese characters.

Any help is welcome
Magda
Re: Inserts Chinese Characters using INSERT INTO doesn't work [message #286794 is a reply to message #286784] Mon, 10 December 2007 02:37 Go to previous messageGo to next message
Michel Cadot
Messages: 64120
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
DML supports any character, check your NLS settings as well as your tool documentation to see if it supports them.

Regards
Michel
Re: Inserts Chinese Characters using INSERT INTO doesn't work [message #286965 is a reply to message #286794] Mon, 10 December 2007 13:29 Go to previous message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
http://www.orafaq.com/forum/t/93676/45693/
Previous Topic: Commit after each DML
Next Topic: ERD tool
Goto Forum:
  


Current Time: Tue Dec 06 16:24:56 CST 2016

Total time taken to generate the page: 0.16004 seconds