Home » Infrastructure » Linux » Oracle 10g R1 on Oracle Enterprise linux (Oracle 10g R1 on Oracle Enterprise linux)
Oracle 10g R1 on Oracle Enterprise linux [message #284106] Wed, 28 November 2007 22:30 Go to next message
gkrishn
Messages: 491
Registered: December 2005
Location: Putty a dark screen
Senior Member
Hi ,
Has anyone installed Oracle 10g R1 on Oracle enterprise linux ?
I had installed Oracle 10g R2 on Oracle EL ,but facing problem with 10g R1 .

It fails during Operating system check .Says it support only some versions of RHEL and SUSE .

any clue ?
Re: Oracle 10g R1 on Oracle Enterprise linux [message #284109 is a reply to message #284106] Wed, 28 November 2007 23:09 Go to previous messageGo to next message
BlackSwan
Messages: 23159
Registered: January 2009
Senior Member
no promises given & advice taken at own risk

./runInstaller -ignoreSysPrereqs

./runInstaller -help
will show other possible options
Re: Oracle 10g R1 on Oracle Enterprise linux [message #284129 is a reply to message #284106] Thu, 29 November 2007 00:05 Go to previous messageGo to next message
Michel Cadot
Messages: 60012
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
What is the need to install 10gR1 now?

Regards
Michel
Re: Oracle 10g R1 on Oracle Enterprise linux [message #284161 is a reply to message #284106] Thu, 29 November 2007 01:16 Go to previous messageGo to next message
gkrishn
Messages: 491
Registered: December 2005
Location: Putty a dark screen
Senior Member
I am learning how to upgrade from 10g R1 to 10g R2 in linux platform (on Oracle Enterprise linux).

initialy i had installed 10g R2 on Oracle Enterprise linux,but face problem only with 10g R1
Re: Oracle 10g R1 on Oracle Enterprise linux [message #284170 is a reply to message #284161] Thu, 29 November 2007 01:35 Go to previous messageGo to next message
Michel Cadot
Messages: 60012
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Oh! OK.

Regards
Michel
icon14.gif  Re: Oracle 10g R1 on Oracle Enterprise linux [message #284186 is a reply to message #284106] Thu, 29 November 2007 02:06 Go to previous message
gkrishn
Messages: 491
Registered: December 2005
Location: Putty a dark screen
Senior Member
Great moment!!i could intsall 10g R1 on Oracle Enterprise linux Smile

Thanks anacedent for the valuble tip .
./runInstaller -ignoreSysPrereqs worked for me.

------In addition----------for those who trying to install Oracle on linux and get DISPLAY errors.

i used to face problems always with DISPLAY parameter.
[root@kitcomp ~]# xhost +
xhost: unable to open display ":0.0"

Most of the time just a reboot resovled the problem.Just follow this steps.

1)reboot the machine
2)login as root ,and make sure x server is running.
if u are in a GUI mode(GNOME,or KDE) x server is already running.Still u may face issues iwth DISPLAY.so you can confirm this from command prompt.
[root@kitcomp ~]#xclock -- thsi would pop up a clock.
or issue a command ps -eaf |grep "X "| grep -v grep -- would show u the x server process.
this way just ensure x server is running.
3)as root user, just issue xhost+ command.
you should get a message something like "access control disabled for all clients"

4)login to Oracle user and issue command
export DISPLAY=:0.0
then execute runInstaller from database dump directory
[oracle@kitcomp ~]# ./runInstaller

Above are the steps i did during Oracle 10g R1 installation on Oracle enterprise Linux.I am just blind about X server and stufss .Anyway it worked for Laughing

Now i have to sit and read,the concept of x-server.

Cheers !!! guys
Previous Topic: how do i check if X_windows server is started
Next Topic: Setting oraenv
Goto Forum:
  


Current Time: Sun Dec 21 20:33:16 CST 2014

Total time taken to generate the page: 0.04285 seconds