Home » RDBMS Server » Networking and Gateways » newbie: database link not active
newbie: database link not active [message #283996] Wed, 28 November 2007 09:40 Go to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
Hi!

A developer have a problem with their DB link. It returns a

The Database Link is not active.
ORA-12154: TNS:could not resolve the connect identifier specified

The dev got it with Grid Control, SQL PLus and SQL developer.

The connect identifier is specified in the tnsnames.ora file. We have been able to ping it using tnsping.

When Im trying to test it using Enterprise Manager I only get this:

The Database Link is not active.
ORA-02019: connection description for remote database not found

So, any ideas how to proceed from here?
Re: newbie: database link not active [message #283997 is a reply to message #283996] Wed, 28 November 2007 09:44 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
>So, any ideas how to proceed from here?
SEARCH this forum for ORA-12154 for this FAQ!
Re: newbie: database link not active [message #283998 is a reply to message #283996] Wed, 28 November 2007 09:51 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

After solved First ORA-12514 error, if you still face problem then check below desc.

ORA-02019: connection description for remote database not found

Cause: An attempt was made to connect or log in to a remote database using a connection description that could not be found.

Action: Specify an existing database link. Query the data dictionary to see all existing database links. See your operating system-specific Net8 documentation for valid connection descriptors.

[Updated on: Wed, 28 November 2007 09:51]

Report message to a moderator

Re: newbie: database link not active [message #284241 is a reply to message #283996] Thu, 29 November 2007 03:52 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
Hi!

They have recreated the DB link and now I get a ORA-12154 when trying to test it using EM.

I have tried this:
select * from dual@dblink;
and that works.

So, are there many tnsnames.ora files? Because the tnsnames.ora looks correct to me. And if there where any thing wrong in it the select statement would not work, would it?
Re: newbie: database link not active [message #284250 is a reply to message #284241] Thu, 29 November 2007 04:12 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Again read Ana reply, your sql statement is correct but just need to check tnsnames.ora file.
Re: newbie: database link not active [message #284252 is a reply to message #284250] Thu, 29 November 2007 04:16 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
Hi!

But the tnsnames.ora file looks fine. How else could I issue the select statement succesfully?

(searching after ORA-12154 gets a lot of crappy hits. Many that not even includes this particular error code)
Re: newbie: database link not active [message #284254 is a reply to message #284252] Thu, 29 November 2007 04:23 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

How can we know your tnsnames.ora file is correct.
ORA-12514:
TNS:listener does not currently know of service requested in connect descriptor

Cause:
The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified a service name for a service (usually a database service) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.

Action:
- Wait a moment and try to connect a second time.
- Check which services are currently known by the listener by executing: lsnrctl services <listener name>
- Check that the SERVICE_NAME parameter in the connect descriptor of the net service name used specifies a service known by the listener.
- If an easy connect naming connect identifier was used, check that the service name specified is a service known by the listener.
- Check for an event in the listener.log file.

[EDITED by LF: removed blank lines]

[Updated on: Thu, 29 November 2007 14:32] by Moderator

Report message to a moderator

Re: newbie: database link not active [message #284393 is a reply to message #284254] Thu, 29 November 2007 09:10 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
Hi!

None of the above is wrong...this is really strange.

Regards
H
Re: newbie: database link not active [message #285671 is a reply to message #283996] Wed, 05 December 2007 04:51 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
hi!

Well, some one had closed the port...we have reopen the port and the DBlink works fine.
Re: newbie: database link not active [message #285672 is a reply to message #285671] Wed, 05 December 2007 04:54 Go to previous message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Thanks for the feedback, we add it to the points to check when getting this error.

Regards
Michel
Previous Topic: connect using tnsname
Next Topic: Client Server Communication in Oracle 9i
Goto Forum:
  


Current Time: Sat Dec 03 10:14:56 CST 2016

Total time taken to generate the page: 0.11105 seconds