Home » RDBMS Server » Server Utilities » DataPump Error
DataPump Error [message #282089] Tue, 20 November 2007 19:20 Go to next message
DaveHatz
Messages: 3
Registered: November 2007
Location: Aliso Viejo, CA
Junior Member
We just installed 10g and we are trying to export once of the schemas. I have tried both EXPDP and EXP and I am getting the same results everytime. I have granted EXP_FULL_DATABASE to my user.

Here is the errors I am getting:

UDE-00008: operation generated ORACLE error 6550
ORA-06550: line 1, column 17:
PLS-00302: component 'DBMS_OUTPUT' must be declared
ORA-06550: line 1, column 13:
PL/SQL: Statement ignored
ORA-06550: line 1, column 56:
PLS-00302: component 'DBMS_DATAPUMP' must be declared
ORA-06550: line 1, column 52:
PL/SQL: Statement ignored

I am not a DBA but have been using 9i for about 4 years and just jumped to 10g. I come from the programming side of the shop. If anyone could shed some light on this problem for me, I would appreciate it.

Thanks,
Dave Hatz
Re: DataPump Error [message #282091 is a reply to message #282089] Tue, 20 November 2007 19:39 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
Yes, you got errors.
However we do not have the foggiest idea EXACTLY what you did to get the errors.

FWIW - both exp & expdp are command line utilites; which means they are NOT invoked from inside SQL*Plus.

Both are document in the Utilities Manual found at http://tahiti.oracle.com
Re: DataPump Error [message #282092 is a reply to message #282091] Tue, 20 November 2007 19:52 Go to previous messageGo to next message
DaveHatz
Messages: 3
Registered: November 2007
Location: Aliso Viejo, CA
Junior Member
I ran the following command from the command line :

expdp user/password@orcl directory=my_dir dumpfile=EXP.dmp NOLOGFILE=y
Re: DataPump Error [message #282115 is a reply to message #282089] Tue, 20 November 2007 22:58 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Which user your using for export operation ?

[Updated on: Tue, 20 November 2007 22:59]

Report message to a moderator

Re: DataPump Error [message #282122 is a reply to message #282089] Tue, 20 November 2007 23:29 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Either lack of privilege or package is not installed.
Re: DataPump Error [message #282287 is a reply to message #282122] Wed, 21 November 2007 06:45 Go to previous messageGo to next message
DaveHatz
Messages: 3
Registered: November 2007
Location: Aliso Viejo, CA
Junior Member
I have given the role of EXP_FULL_DATABASE to the user that is running the datapump. I am NOT using the SYS user.

I am guessing that I don't have the package installed. How can I check to see if the package is installed?
Re: DataPump Error [message #282400 is a reply to message #282089] Wed, 21 November 2007 22:03 Go to previous message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

http://download.oracle.com/docs/cd/B19306_01/server.102/b14237/scripts002.htm
Previous Topic: How to take backup for only tables not other objects
Next Topic: create a control file to load data-table
Goto Forum:
  


Current Time: Sun Dec 04 00:18:43 CST 2016

Total time taken to generate the page: 0.06370 seconds